Closed Bug 343847 Opened 15 years ago Closed 8 years ago

window.status text persists when switching to a different tab

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: jab_creations, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060706 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060706 Minefield/3.0a1

The original error is that when a window.status is set and the user changes the tab that the status of the previous tab remains.

In build 20060706 the status is completely lost when toggling between tabs.  If tab A sets a status and the user switches to tab B and then back to tab A the status no longer appears.

Reproducible: Always

Steps to Reproduce:
1. Open any page that sets window.status.
2. Toggle to a different tab without window.status.
3. Toggle back to the tab that had set window.status.

Actual Results:  
The window.status disappeared when returning to the original tab where the window.status was initially set.

Expected Results:  
When toggling back to a tab that set window.status the window.status should be restored.  Related to another bug the window.status should not appear for other tabs (unless of course they have the same page setting the same status).

1.) There are too many poorly created bug reports.

2.) Bugs are taking way too long to address while new technologies are implemented practically overnight.

3.) Most bug fixes I see are **** requiring new bugs because the original poster of the bug did not properly create the bug report.  This is keeping Opera's rendering engine superior to Geckos.
Looks like a dupe of bug 104532 - marking as dupe. If its not can someone please correct.

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
No duplicate of bug 104532 (which BTW is a SeaMonkey bug, bug 327604 would have been the Firefox one), but AFAICT a valid bug which got (more prominently) exposed by the fix to bug 327604.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Component: General → Tabbed Browser
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Blocks: 327604
Summary: window.status toggling tab error → window.status text disappears after switching tabs
I see this basically also in old builds like 1.0.7.
At the moment there are two possibilities: 1. when you open a tab in the background the statusbar message will stay and also persist in the next tab, and 2. when you open it in the foreground the message in the statusbar message will disappear on both tabs. Very few people will ever notice that there should be a statusbar message because the pref is off by default.  
>> Very few people will ever notice ...

Let's not degrade the bugs I post please.  A bug is a bug and it is only your opinion that only a "few" people pay attention to the status bar.  If my site's status bar text appears on tabs for other sites my site's good name could be associated with spyware.  So please keep to constructive notes only please.

Bug Clarification: When a new tab is opened in Firefox 20060426 in the background the status text remains.  Clicking on a tab that immediantly gains focus removes the status text. So Ria's post ultimately brings this bug clarification, thank you.
I think we simply need separate status bars for every tab.
_All_ other browsers have this...
Duplicate of this bug: 371243
QA Contact: general → tabbed.browser
Duplicate of this bug: 481576
We no longer have a status bar that displays window.status
Status: NEW → RESOLVED
Closed: 15 years ago8 years ago
Resolution: --- → INVALID
(In reply to :Felipe Gomes from comment #8)
> We no longer have a status bar that displays window.status

We have the status panel that supports window.status, which is disabled by default (dom.disable_window_status_change). Enabling it actually exposes the opposite of this bug: The status text is displayed across different tabs. We should either fix this or completely remove support for window.status.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Summary: window.status text disappears after switching tabs → window.status text persists when switching to a different tab
Depends on: 842017
Support for displaying window.status has been removed in bug 842017.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.