Crash [@ js_AllocStack] with this testcase using Java and quickly changing tabs

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({crash, regression, testcase})

Trunk
x86
Windows XP
crash, regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Doesn't crash Firefox1.5, in fact in those builds I get to see bug 343605.
The testcase I'll attach is virtually identical to the one of bug 343605.

To reproduce:
- Open a new tab
- Switch back to the testcase in case you switched to the new tab
- Reload the page
- While this page is busy make the java plugin work, switch to the other tab.

Result: crash

Talkback ID: TB20766555Q
js_AllocStack   js_InternalInvoke   JS_CallFunctionValue   nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject   nsXPCWrappedJSClass::DelegatedQueryInterface
(Reporter)

Comment 1

12 years ago
Created attachment 228638 [details]
testcase

Comment 2

12 years ago
I don't see a crash. 
I see second tab as "Applet notinited" in status bar.
And error Console gets
Error: [Exception... "'Permission denied to get property XULElement.accessKey' when calling method: [nsIDOMXULLabelElement::accessKey]"  nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame :: https://bugzilla.mozilla.org/attachment.cgi?id=228638 :: doe :: line 6"  data: no]
Source File: https://bugzilla.mozilla.org/attachment.cgi?id=228638
Line: 6

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060706 Minefield/3.0a1
(Reporter)

Comment 3

12 years ago
Yeah, that's bug 343605. I just tried this myself again.
To get the crash more easier, download the testcase locally to your computer and try it out there. I usually succeed within 5 times trying.
Another Talkback ID: TB20893384W
Hmm... I can't seem to reproduce on Linux.  Might be Windows-specific, or maybe I'm just not hitting the timing right.  :(
(Reporter)

Comment 5

12 years ago
Created attachment 229470 [details]
testcase2

Ok, this testcase does all the tab switch itself and usually crashes within 5 seconds for me. Because of enhanced privileges, you need to test it locally.
Sometimes it doesn't crash, probably the js error, I mentioned earlier prevents the script from executing further. In that case, only 1 tab is opened (the testcase should open new tabs indefinitely, with 1 second interval).

Updated

12 years ago
Blocks: 353557

Updated

12 years ago
No longer blocks: 353557
(Reporter)

Comment 6

12 years ago
Ok, after updating to Java Version 1.5.0 (build 1.5.0_10-b03), I don't crash anymore with the testcase, so I'm marking this worksforme.
I still experience bug 343605 and bug 275783 with the testcase, though.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ js_AllocStack]
You need to log in before you can comment on or make changes to this bug.