crash closing a browser window gklayout.dll and [@ PresShell::ReflowEvent::Run]

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
crash after attempting to close a SM window (not the only window open). Window had two tabs, one of them a pdf doducment that had just been saved to disk. 

window after crash has "AppName: seamon~1.exe AppVer: 1.9.20060.4573 ModName: gklayout.dll ModVer:

TB20728642
Stack Signature	PresShell::ReflowEvent::Run 830155ee
Product ID	MozillaTrunk
Build ID	2006070109
Trigger Time	2006-07-08 12:44:15.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	gklayout.dll + (0000b541)
URL visited	
User Comments	1.9.20060.4573 Offset: 0000b541
Since Last Crash	203260 sec
Total Uptime	203260 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp, line 6461
Stack Trace 	
PresShell::ReflowEvent::Run  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsPresShell.cpp, line 6461]
nsThread::ProcessNextEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/threads/nsThread.cpp, line 483]
NS_ProcessNextEvent_P  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpcom/build/nsThreadUtils.cpp, line 225]
nsXULWindow::ShowModal  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 402]
nsContentTreeOwner::ShowAsModal  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsContentTreeOwner.cpp, line 503]
nsWindowWatcher::OpenWindow  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 413]
nsPromptService::DoDialog  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/embedding/components/windowwatcher/src/nsPromptService.cpp, line 659]
nsPromptService::ConfirmEx  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/embedding/components/windowwatcher/src/nsPromptService.cpp, line 346]
nsPrompt::ConfirmEx  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/embedding/components/windowwatcher/src/nsPrompt.cpp, line 286]
nsPluginHostImpl::HandleBadPlugin  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/nsPluginHostImpl.cpp, line 6293]
ns4xPluginStreamListener::CleanUpStream  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp, line 182]
ns4xPluginInstance::Stop  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/modules/plugin/base/src/ns4xPluginInstance.cpp, line 909]
nsObjectFrame::StopPlugin  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsObjectFrame.cpp, line 1392]
nsObjectFrame::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsObjectFrame.cpp, line 494]
nsLineBox::DeleteLineList  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsLineBox.cpp, line 369]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
CanvasFrame::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsHTMLFrame.cpp, line 217]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameManager::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsFrameManager.cpp, line 293]
DocumentViewerImpl::Hide  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp, line 2085]
nsDocShell::SetVisibility  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/docshell/base/nsDocShell.cpp, line 3870]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameList::DestroyFrames  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/generic/nsFrameList.cpp, line 60]
nsFrameManager::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsFrameManager.cpp, line 293]
DocumentViewerImpl::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/layout/base/nsDocumentViewer.cpp, line 1612]
nsDocShell::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/docshell/base/nsDocShell.cpp, line 3623]
nsXULWindow::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 507]
nsWebShellWindow::Destroy  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 834]
nsWebShellWindow::HandleEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 393]
nsWindow::DispatchEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 1102]
nsWindow::DispatchStandardEvent  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 1142]
nsWindow::ProcessMessage  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 4156]
nsWindow::WindowProc  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0xb4c0 (0x77d4b4c0)
USER32.dll + 0xb50c (0x77d4b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
USER32.dll + 0xb3f9 (0x77d4b3f9)
uxtheme.dll + 0x3c20 (0x5ad73c20)
uxtheme.dll + 0x1e300 (0x5ad8e300)
uxtheme.dll + 0x1ac7 (0x5ad71ac7)
uxtheme.dll + 0x1b3d (0x5ad71b3d)
USER32.dll + 0xbb15 (0x77d4bb15)
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0xc63f (0x77d4c63f)
USER32.dll + 0xc665 (0x77d4c665)
nsWindow::WindowProc  [c:/builds/tinderbox/MozillaTrunk/WINNT_5.0_Clobber/mozilla/widget/src/windows/nsWindow.cpp, line 1298]
USER32.dll + 0x8734 (0x77d48734)
USER32.dll + 0x8816 (0x77d48816)
USER32.dll + 0xb4c0 (0x77d4b4c0)
USER32.dll + 0xb50c (0x77d4b50c)
ntdll.dll + 0xeae3 (0x7c90eae3)
USER32.dll + 0xb903 (0x77d4b903)
uxtheme.dll + 0x2881f (0x5ad9881f)

Comment 1

12 years ago
oh brother.

reporter: you had a plugin crash.

darin: this bug is yours. please don't handle events while we have app dialogs up like this one.
Assignee: general → nobody
Component: General → General
Product: Mozilla Application Suite → Core
QA Contact: general → general

Updated

12 years ago
Assignee: nobody → darin
Component: General → XPCOM
QA Contact: general → xpcom

Updated

12 years ago
Summary: crash closing a browser window gklayout.dll and PresShell::ReflowEvent::Run → crash closing a browser window gklayout.dll and [@ PresShell::ReflowEvent::Run]
I've filed bug 346521, which has the same stacktrace as this bug, but it has a reproducable way of getting the crash for me.
Can this be resolved (as dupe of Bug 346521) now that Bug 346521 was fixed ?

Comment 4

11 years ago
-> reassign to default owner
Assignee: darin.moz → nobody
(Reporter)

Comment 5

11 years ago
(In reply to comment #3)
> Can this be resolved (as dupe of Bug 346521) now that Bug 346521 was fixed ?

I don't know, but I've not seen the problem for a long time.

=> WFM 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

7 years ago
Crash Signature: [@ PresShell::ReflowEvent::Run]
You need to log in before you can comment on or make changes to this bug.