Status

()

RESOLVED WONTFIX
12 years ago
12 years ago

People

(Reporter: dao, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060710 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060710 Minefield/3.0a1

It looks like bug 344048 will reduce browser.tabs.tabMinWidth from 120 to 60 px. (Though it's still a proposal.)

That would be fine since the favicon + 3 or 4 characters is good enough for picking one particular tab. Yet there are sites without a favicon, so the most important indication is missing. I think the best way to handle these cases is to remove the default tab icon. This would give approximately 4 more characters.

The default icon could be removed at all (I hardly see its value) or as soon as browser.tabs.tabClipWidth is reached.

Reproducible: Always




I've achieved this manually via userChrome.css:

> .tabbrowser-tabs tab:not([image]) .tab-icon { display: none; }
> .tabbrowser-tabs tab[busy] .tab-icon { display:-moz-box; }
(Reporter)

Updated

12 years ago
Blocks: 308396, 318168, 344048
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

12 years ago
Created attachment 228917 [details]
default icon vs. no default icon

CSS updated to:
.tabbrowser-tabs tab:not([image]):not([busy]) .tab-icon { display: none; }

Note that without the default icon, the width of some tabs (not only those without an icon) is 59 px. browser.tabs.tabMinWidth set to 60.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Note that without the default icon, the width of some tabs (not only those
> without an icon) is 59 px. browser.tabs.tabMinWidth set to 60.

Okay, this happens because of the scroll buttons. Also note that they cause the tab height to expand by 2 px.
(Reporter)

Comment 3

12 years ago
Created attachment 228919 [details]
default icon vs. no default icon

Comparison without scroll buttons in both cases.
Attachment #228917 - Attachment is obsolete: true
(Reporter)

Comment 4

12 years ago
Now what do you think? Any chance we can try this for Beta 2?

Even if browser.tabs.tabMinWidth is supposed to be increased again (90 according to bug 343251 comment 22), I still think this would be useful.
The problem is twofold:

It looks weird to not have an icon, since you lose some the per-tab symmetry.
This would cause labels to jump around as favicons load, which creates a jittery look.

Getting an extra letter or two of some labels isn't worth either of those problems.

Beta 2 isn't the time to try out new UI, in any case, but I think that this is the wrong idea.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

12 years ago
> This would cause labels to jump around as favicons load, which creates a
> jittery look.

Well, I'm using it for months now and it didn't look jittery to me. Note that the throbber is in place when the page loads, a favicon would replace it seamlessly.

I'd be happy if this respected browser.tabs.tabClipWidth, where the "jitter" is present anyway (close button gets hidden). Also this would affect heavy users mainly; they have to live with real jitter anyway, if you take the tab scroll buttons for example.

> Getting an extra letter or two of some labels isn't worth either of those
> problems.

It's usually three letters, which increases the information by 100% (60px) respectively 50% (90px).

> Beta 2 isn't the time to try out new UI

Uhmm ... Theme refresh? Pref panel rewrite? Tab overflow? Looks like the whole UI rework is targeted mainly for Beta 2, so this seems like a very weak argument against such a cosmetic change.
You need to log in before you can comment on or make changes to this bug.