Bookmarks metadata (created/last accessed date) cannot be removed; privacy issue.

RESOLVED WONTFIX

Status

()

--
minor
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: nrlz, Unassigned)

Tracking

({privacy})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Currently, the bookmarks system keeps track of when a bookmark is created and when it was last accessed. This information cannot be removed without manually editing the bookmarks.html file, and there appears to be no way of specifying that this information NOT be saved in the future.

This may potentially be a privacy issue for some people, whom don't realize that their browsing history may also be recorded in the bookmarks metadata, in addition to the browser history records.

I propose that we have an option to turn off the saving of this information and an option to purge this data.

Reproducible: Always

Steps to Reproduce:
1. Bookmark a website of a controversial nature.
2. Visit it often.
3. Invite your mother-in-law over for dinner, but beforehand, purge your browser history.
4. Tell your mother-in-law that that bookmark was old and was part of a research project you did years ago.
5. You mother-in-law inspects your bookmarks metadata.
6. She finds out you visited it last night.
The next Firefox version will be Firefox 2.0. Also this release will have the same bookmarks system. Firefox 3.0 will be based on the new Places bookmarks/history system. They will be stored in a bookmarks_history.sqlite file and if I open it I see no clearly recognizable dates. I don't know how smart your mother-in-law is, but you can set it to be opened by windows scripting host or something like that and then it will do nothing when someone clicks on it. As it uses bookmarks.html to import the old bookmarks from you need to delete this file or rename it to something else.
You can try it out but the test builds are _very_ buggy at the moment at not for normal use for people who want a stable browser.
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> [snip]
> Firefox 3.0 will be based on the new Places
> bookmarks/history system. They will be stored in a bookmarks_history.sqlite
> file and if I open it I see no clearly recognizable dates.
> [snip]

Is that because it isn't complete yet or were dates not included in the new system? Because it seems rational for them to have ported the dates system across to Firefox 3.0 since it is a useful feature to some.
They are certainly present but not visible on first glance when I try to open the file in a text editor, and that is what this bug is about: that you can see dates when you open the file in a text editor. Or did I misunderstand the problem?
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> They are certainly present but not visible on first glance when I try to open
> the file in a text editor, and that is what this bug is about: that you can see
> dates when you open the file in a text editor. Or did I misunderstand the
> problem?
> 

You can see the dates in the Manage Bookmarks window.
Bookmarks -> Manage Bookmarks -> View -> Show columns -> Added/Last Modified/Last Visited.

I think the problem is the fact that you cannot clear this information (not even in the Bookmark properties window) and that you cannot opt to not save this information.
In case everyone uses the same browser maybe you could find an bookmark extension that strips data off. Its just what effort you want to do for your privacy. Putting the whole program in a hidden folder only accessible by yourself or putting it on a USB stick are other possibilities.
See the Mozillazine forums for help on this: http://forums.mozillazine.org/viewforum.php?f=38 

Comment 6

12 years ago
Perhaps clearing history should also clear the last-visited and/or created dates on bookmarks?  Although I bet lots of users clear history often but like having those dates be accurate for bookmarked files, and just don't bookmark porn sites.
Keywords: privacy
(Reporter)

Comment 7

12 years ago
I just looked in Opera and in its "Delete private data" dialog, there is a checkbox for "Clear bookmark visited time".

Comment 8

10 years ago
saved data for bookmarks are dateAdded and lastModified, i can't see how those could be privacy involved, if the bookmark exists is clear that you've added and maybe modified it.
Last Visited is instead correctly cleared since it's part of history.

Updated

10 years ago
Whiteboard: wontfix?
1. i don't see a clear use-case for clearing the date a bookmark was created.

2. the time it was last visited *is* cleared with history (comment #8).

marking WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?
You need to log in before you can comment on or make changes to this bug.