Search keyword suggestion

RESOLVED DUPLICATE of bug 261124

Status

()

Firefox
Search
--
enhancement
RESOLVED DUPLICATE of bug 261124
12 years ago
12 years ago

People

(Reporter: Dylan McCall, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

Few quick suggestions for that:
First, it took me a while to figure out what it's really doing.
Perhaps the context menu option should be reworded, or a tooltip added, or the Add Bookmark window renamed (in that case), to make it easier to comprehend.

As it is, it seems like a failed bookmark thing that adds itself to the Bookmarks menu and seems to search for nothing.

My suggestion is to change this so that it behaves more like the Search Engine Wizard extension.
Instead of a mysterious bookmark, it could add an actual search plugin. This would be easier to figure out, we wouldn't have an unuseable bookmark sitting in the Bookmarks menu, and it would be very cool!

Reproducible: Always

Steps to Reproduce:
1. Find a nitwit such as myself.
2. Get them to right click a search form field.
3. See how long it takes them to figure out how it works.



Expected Results:  
Search engine should have been added to the options in the Search Box.
Component: Find Toolbar / FastFind → Search
QA Contact: fast.find → search

*** This bug has been marked as a duplicate of 261124 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.