If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Close Tab does not close window when "Hide the tab bar when only one web site is open" is turned off.

RESOLVED DUPLICATE of bug 341067

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED DUPLICATE of bug 341067
11 years ago
11 years ago

People

(Reporter: Jonathan Gardiner, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

When "Hide the tab bar when only one web site is open" is turned off, Close Tab, either through the menu or the keyboard short (cmd-w) will not close the window if there is only one tab open. Instead, replaces the last tab with a blank page.

Reproducible: Always

Steps to Reproduce:
1. Disable "Hide the tab bar when only one web site is open" in Preferences.
2. Open a new window with one tab open.
3. Choose Close Tab, either through the File menu or keyboard shortcut (cmd-w.)

Actual Results:  
Window changes to a blank tab.

Expected Results:  
Window should close.

I have tested this on both Windows and Mac OS X. I have not been able to reproduce this in Windows. This problem has been observed on Mac OS X 10.4 (ppc).

It is certainly an annoyance, but either turning on the hide tab bar feature, or using close window instead of close tab will produce the desired results.

Comment 1

11 years ago
Not closing the window is the intended behavior (see bug 236721). If you enable the "Hide the tab bar..." option, the "Close Tab" entry in the File menu should change to "Close" when only one tab is open. With "Hide the tab bar..." disabled, that entry will remain "Close Tab" and do precisely that.

I'm rather worried that you're not able to reproduce this issue on Windows though. Have you been using a recent nightly for testing there as well? Note that this behavior has been introduced with Firefox 2.0 beta 1.
(Reporter)

Comment 2

11 years ago
Sorry, I just tested this very quickly on a Windows box while I was tired. Apparently, despite clicking on the download link for 2.0 Beta 1, I ended up at the page to download 1.5.0.4. Even now, viewing the page http://www.mozilla.com/products/download.html?product=firefox-2.0b1&os=win&lang=en-US in Internet Explorer puts me at the page to download 1.5.0.4. I should probably file a bug about that, if I can reproduce it somewhere else.

In either case, I find this extremely annoying, especially in Mac OS X where closing the last window does not quit the application. In Mac OS X, regardless of the application, one expects Cmd-w to close the top window and/or tab. It's how one keeps their desktop clean while working. If anything, Cmd-t while no window is open should open a new window. You can enable tabs in Safari to see how a Mac user expects an application to behave.

I also frequently use Windows, and find it annoying there too, simply because it's what I expect Ctrl-w to do.

Changing bug to all platforms.
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
Version: unspecified → 2.0 Branch

Comment 3

11 years ago
Since this is the intended behavior, you'll have to have better arguments than just that the new behavior isn't what you expect. On Windows at least, the behavior is now more coherent (visible tab bar = MDI mode where Ctrl+W never closes a window; invisible tab bar = SDI mode where Ctrl+W may close the window).

I don't know how this is handled on the Mac where there are hardly and MDI apps to start with, but I doubt that the devs will want to make this behavior not consistent across all platforms. Probably INVALID.
(Reporter)

Comment 4

11 years ago
I don't follow your reasoning as to why the existence of the tab bar makes Firefox MDI. If Firefox was an MDI app, you would be able to tile tabs so you could see two of them at the same time, and have the application running with no page open at all.

I understand why some people might want this feature, as its been in an extension I've been using on Windows since early Firebird builds, but I don't believe it should be forced on users who have gotten used to the consistent interface just because a few people like it the other way. Even if there's no GUI for it, this should probably be a preference that isn't tied to hiding the tab bar. The two are completely unrelated.

Comment 5

11 years ago
Obviously Firefox is neither pure SDI because you could always open new tabs nor pure MDI because of the limitations you mention. The now corrected behavior corresponds however to how it was supposed to be done since day 1 (see http://tinyurl.com/l44au where the File menu entry is changed between "Close [Window]" and "Close Tab" depending on tab bar visibility).

The main reason for this is that Ctrl+W should behave like in IE when people don't use tabs at all and like in any MDI application if they obviously do. The "Hide the tab bar..." pref is the closest you get to let them decide between the two modes.

The expected solution for people who got used to the previous (wrong) behavior is probably to get an extension (introducing new prefs to comfort all people is left to SeaMonkey). Of course you might have further arguments for
* why Close TAB should close the WINDOW
* why Ctrl+W should close the window although in almost all other cases (the IE parity case excluded) it just closes a tab (opposed to Ctrl+Shift+W and Alt+F4).

Comment 6

11 years ago
Never mind.

*** This bug has been marked as a duplicate of 341067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.