Last Comment Bug 344785 - truncated replacement tokens in pipnss.properties
: truncated replacement tokens in pipnss.properties
Status: RESOLVED FIXED
: fixed1.8.0.7, fixed1.8.1
Product: Mozilla Localizations
Classification: Client Software
Component: ko / Korean (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Channy Yun [:channy]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-15 15:54 PDT by Daniel Veditz [:dveditz]
Modified: 2006-08-25 11:46 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
string changes (518 bytes, patch)
2006-07-16 21:51 PDT, Channy Yun [:channy]
l10n: review+
dveditz: approval1.8.0.7+
Details | Diff | Splinter Review

Description Daniel Veditz [:dveditz] 2006-07-15 15:54:51 PDT
in pipnss.properties the initial replacement token is mangled in the strings

  nick_template
  nick_template_with_num

Both start with "%1$\uC758", missing the 's' type specifier, which displays as a literal "%1$" (or perhaps results in an error leading to a blank string, I haven't looked at error handling in the text formatting code). Should be "%1$s\uC758" unless the \uC758 was a mistaken translation of the character s
Comment 1 Channy Yun [:channy] 2006-07-16 15:53:36 PDT
I confirmed this bug. But, it will be changed Firefox 2 beta 2. 
Axel, can I changed it 1.8.0 branch?
Comment 2 Axel Hecht [:Pike] 2006-07-16 21:01:36 PDT
Please create a patch and request approval1.8.0.6.
Comment 3 Channy Yun [:channy] 2006-07-16 21:51:09 PDT
Created attachment 229431 [details] [diff] [review]
string changes
Comment 4 Channy Yun [:channy] 2006-07-24 17:56:07 PDT
Axel, please review this patch.
Comment 5 Axel Hecht [:Pike] 2006-07-25 00:48:44 PDT
Comment on attachment 229431 [details] [diff] [review]
string changes

From a review point of view, this is fine. Please keep the approval flag open and wait with landing until we opened the development on 1.5.0.6.
Comment 6 Daniel Veditz [:dveditz] 2006-08-15 15:11:35 PDT
Comment on attachment 229431 [details] [diff] [review]
string changes

approved for 1.8.0 branch, a=dveditz for drivers
Comment 7 Daniel Veditz [:dveditz] 2006-08-15 15:12:14 PDT
Needs fixing in 1.8.1 and trunk too, right?
Comment 8 Channy Yun [:channy] 2006-08-18 11:58:57 PDT
(In reply to comment #7)
> Needs fixing in 1.8.1 and trunk too, right?
> 

I did it. Thanks.
Comment 9 Daniel Veditz [:dveditz] 2006-08-18 15:58:54 PDT
Ok, on July 23, along with a bunch of other stuff. I missed it because I was looking for a reference to this bug number. Still needed on the 1.8.0 branch it looks like, right?
Comment 10 Daniel Veditz [:dveditz] 2006-08-25 11:46:45 PDT
Looks like this got checked in on Aug 23

Note You need to log in before you can comment on or make changes to this bug.