firefox 2.0 beta 1 - DT_TEXTREL warnings

RESOLVED DUPLICATE of bug 319012

Status

()

RESOLVED DUPLICATE of bug 319012
12 years ago
12 years ago

People

(Reporter: peper, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.3 (like Gecko)
Build Identifier: 

Although i have managed to compile(see bug #344818) firefox i still get a lot of DT_TEXTREL warnings like:

i686-pc-linux-gnu-g++ -DGENTOO_NSPLUGINS_DIR="/usr/lib/nsplugins" -DGENTOO_NSBROWSER_PLUGINS_DIR="/usr/lib/nsbrowser/plugins"  -fno-rtti -fno-handle-exceptions  -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -march=athlon-xp -pipe -Wno-return-type -w -freorder-blocks -fno-reorder-functions -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -ffunction-sections -O2  -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -fPIC -shared -Wl,-z,defs -Wl,-h,libgtkembedmoz.so -o libgtkembedmoz.so  gtkmozembedmarshal.o gtkmozembed2.o EmbedPrivate.o EmbedWindow.o EmbedProgress.o EmbedContentListener.o EmbedEventListener.o EmbedWindowCreator.o EmbedPrompter.o GtkPromptService.o       -Wl,--whole-archive ../../../../dist/lib/libembed_base_s.a ../../../../dist/lib/libprofdirserviceprovider_s.a  -Wl,--no-whole-archive -L../../../../dist/bin -lxpcom -lxpcom_core  -L../../../../dist/bin -Wl,-R/usr/lib/nspr -L/usr/lib/nspr -lplds4 -lplc4 -lnspr4 -lpthread -ldl   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0   -ldl -lm
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in object.
chmod +x libgtkembedmoz.so

Full compile log: http://dev.gentoo.org/~dragonheart/mozilla-firefox/firefox-2.0_beta1-compile.log
Scanelf log: http://dev.gentoo.org/~dragonheart/mozilla-firefox/firefox-2.0_beta1-scanelf-textrel.log

Reproducible: Always
(Reporter)

Updated

12 years ago
Version: unspecified → 2.0 Branch

Comment 1

12 years ago
Textrels (DT_TEXTREL) are important because they place a large load on the system to handle the runtime relocation of shared objects (http://www.gentoo.org/proj/en/hardened/pic-guide.xml).

More information can be found here:
http://www.gentoo.org/proj/en/hardened/pic-internals.xml

Thankfully the fix is quite easy. Compile with CFLAGS=-fPIC for objects that get linked into shared libraries. More information available here:
http://www.gentoo.org/proj/en/hardened/pic-fix-guide.xml
(Reporter)

Comment 2

12 years ago
My system info:
Portage 2.1.1_pre2-r8 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.17-gentoo-dione i686)
=================================================================
                       System Settings
=================================================================
System uname: 2.6.17-gentoo-dione i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.12.1
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.3.5, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: [Not Present]
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5

Comment 3

12 years ago
This is caused by GCC bugs. use "ac_cv_visibility_pragma=no" in mozconfig to workaround the gcc bug. (It should cause link-time errors on x86_64).

*** This bug has been marked as a duplicate of 319012 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.