Feature Request: put bookmarks into some RDBMS or use some external program

RESOLVED DUPLICATE of bug 345055

Status

--
enhancement
RESOLVED DUPLICATE of bug 345055
13 years ago
11 years ago

People

(Reporter: weigelt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920

Similar to bug 345055:

Add support for putting the bookmarks either into some relational (SQL) database or query it via some external process.


Reproducible: Always
(Reporter)

Comment 1

13 years ago
The history issue of bug 345055 could be solved by simply mapping the history into the bookmark database. Maybe history is folder "HISTORY/" and user bookmarks start at "BOOKMAKRS/". This way other things could also be mapped in there.
(Reporter)

Comment 2

11 years ago
Ah, and the whole bookmark / link object storage could be done with "flat" files within an filesystem hierachy. Synthetic filesystems can be used for putting the actual data into virtually any kind of database (LDAP, RDBMS, ...).

Please have a look at Plan9 / 9P2000 and libmixp.

Now that (on the trunk) Bookmarks and History are stored in a common SQL database (places.sqlite in your profile), I believe that whatever would solve bug 345055 would fix this one too. Marking DUPLICATE.
Assignee: general → nobody
Component: General → Bookmarks
OS: Linux → All
QA Contact: general → bookmarks
Hardware: PC → All
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 345055
You need to log in before you can comment on or make changes to this bug.