Closed Bug 345163 Opened 14 years ago Closed 14 years ago

Once More about '\' in URLs and converting into '%5C'

Categories

(Firefox :: General, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: petr-gurianov, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060712 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060712 Minefield/3.0a1

As Bug 279904 says. FireFox have a trouble with converting '\' into '%5C' in URL, not in script parameters. At some sites in url tag there are links like 'http://server/osk/Form\index.html' but correct address is 'http://server/osk/Form6/index.html' and Apache server (on Windows) when received converted URL 'http://server/osk/Form6%5Cindex.html' says 'The requested URL /osk/Form6\index.html was not found on this server'.
May be add optional functionality to convert '\' into '/' in URls.

Reproducible: Always

Steps to Reproduce:
1.Open link with '\' in url html tag
2.See the Apache page "Not Found
The requested URL /osk/Form6\index.html was not found on this server."
3.

Actual Results:  
See the Apache page "Not Found
The requested URL /osk/Form6\index.html was not found on this server."

Expected Results:  
May be add optional functionality to convert '\' into '/' in URls.
As stated in bug 64488:

> It is not allowed in URIs as you said.
> However MS's IE allows this, and probably the IIS allows this.
> So, many people, who are even CS major, don't recognize this problem, and when
> they give an URL to their students or.. whomever, they use "\" instead of "/".
> Probably it would be good if the Mozilla translate the \ to /, or Mozilla people
> operate an education site in Spread Firefox website. :)

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This bug really is a duplicate of bug 64488.  Please don't reopen it again.

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.