All users were logged out of Bugzilla on October 13th, 2018

can't run apprunner and viewer at the same time

VERIFIED WONTFIX

Status

()

P2
normal
VERIFIED WONTFIX
20 years ago
10 years ago

People

(Reporter: mikepinkerton, Assigned: dp)

Tracking

Trunk
PowerPC
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
We can't run both viewer and apprunner on the same time on mac. i'm assuming this
is because the registry is left open or something. This works fine on NT.

The problem we see is once viewer is running and you launch apprunner, you get
asserts in rdf because it cannot create resources. I'm assuming (again) this is
because it can't write things into the registry at startup time.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 1

20 years ago
The current repository code opens/closes the registry. And that I was thinking
is a performance problem and am going to change it to make it keep the registry
open all the time. FYI.

I dont know why this would happen. Does it always happen ? Like run viewer let
is show the chrome and dont do anything else to it. Then run apprunner. At this
point, the registry is closed by viewer.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 2

20 years ago
Viewer is dead. Apprunner is the only one that lives.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 3

20 years ago
Marking Verified/Won't Fix.

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: dp → xpcom
You need to log in before you can comment on or make changes to this bug.