Cannot add any new field in editvalues.cgi

RESOLVED FIXED in Bugzilla 3.0

Status

()

--
critical
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: LpSolit, Assigned: LpSolit)

Tracking

({regression, selenium})

2.23
Bugzilla 3.0
regression, selenium
Bug Flags:
approval +
testcase +

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Trying to add a new value in editvalues.cgi returns this error thrown by ThrowUserError():

 The field 'Bugzilla::Field=HASH(0x988ee10)' does not exist or cannot be edited with this interface.
(Assignee)

Comment 1

12 years ago
This is a regression due to bug 344513 where $field is overwritten in field-descs.none.html.
Depends on: 344513
(Assignee)

Comment 2

12 years ago
Created attachment 230029 [details] [diff] [review]
patch, v1
Assignee: administration → LpSolit
Status: NEW → ASSIGNED
Attachment #230029 - Flags: review?(mkanat)

Comment 3

12 years ago
Comment on attachment 230029 [details] [diff] [review]
patch, v1

Looks right to me. I trust you that this fixes the problem.
Attachment #230029 - Flags: review?(mkanat) → review+

Updated

12 years ago
Flags: approval?
Flags: approval? → approval+
(Assignee)

Comment 4

12 years ago
Checking in template/en/default/global/field-descs.none.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/field-descs.none.tmpl,v  <--  field-descs.none.tmpl
new revision: 1.16; previous revision: 1.15
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Flags: testcase+
Keywords: selenium
You need to log in before you can comment on or make changes to this bug.