Closed Bug 345608 Opened 18 years ago Closed 18 years ago

SeaMonkey 1.5a is unstable. When Navigator is open and Window > Mail is chosen, SM crashes.

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 341595

People

(Reporter: michael.graubart7, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060722 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060722 SeaMonkey/1.5a

I have Preferences set to open Navigator — home page at start-up. If I then choose Window > Mail & Newsgroups, SeaMonkey crashes almost every time. (Some addoitional sellcheck dictionaries have been installed.)

I cannot find out how to make TalkBack work; otherwise I could send a TalkBack report.

Reproducible: Sometimes

Steps to Reproduce:
1.Set Preferences so that when SeaMonkey is started, Navigator opens (at a home page).
2.Click Window > Mail & Newsgroups.


Actual Results:  
Almost every time, SeaMonkey crashes.

Expected Results:  
Mail & Newsgroups should open.

eMac G4 PPC, OS X 10.4.7, Classic theme.
This phenomenon is almost certainly due to the installation of the following spellcheck dictionaries: English (UK), French (France), German (Austria), German (Germany), Italian, Latin, Spanish (Spain). After filing this report, I downloaded a new copy of SM 1.5a but did not install these dictionaries, and so far it has remained stable. I should say that I have regularly installed exactly that set of dictionaries in successive builds of SM such as 1.0.2, 1.0.3 and earlier builds of 1.5a, without any trouble.

I should be grateful if someone would tell me how to activate TalkBack.
Version: unspecified → Trunk
One further observation: I have now tried installing only a single spellcheck dictionary, namely English (UK), and at once the instability returned.
Stephen — re Comment #3: all the discussion of the code under Bug 341595 is way above my head. I'm only a poor, humble end-user who sometimes does a bit of testing! 

I tried disabling XUL Cache, and that does stop Mail crashing. But it also stops the installed language dictionaries from being displayed, it seems. And in SeaMonkey 1.1a, the crash doesn't happen whether XUL Cache is disabled or not — but the language dictionaries, though installed, are not displayed whether XUL Cache is disabled or not. So to my mind this points the finger at the language-dictionary display.
(In reply to comment #4)
> Stephen — re Comment #3: all the discussion of the code under Bug 341595 is way
> above my head. I'm only a poor, humble end-user who sometimes does a bit of
> testing! 
> 
> I tried disabling XUL Cache, and that does stop Mail crashing. But it also
> stops the installed language dictionaries from being displayed, it seems. And
> in SeaMonkey 1.1a, the crash doesn't happen whether XUL Cache is disabled or
> not — but the language dictionaries, though installed, are not displayed
> whether XUL Cache is disabled or not. So to my mind this points the finger at
> the language-dictionary display.

Interesting.  Sorry about them not being displayed; I'm not sure how exactly the fastload code works, but I know it's pretty complex, and does a lot of compaction and checks offsets, etc.  Sorry I can't be of more help here; I'm on Windows, and not using multiple dictionaries, either.  Here's hoping they fix bug 341595 relatively soon!
I think this is connected with Bug 345612 (as well as with 341595), and with XUL Cache (Preferences).
(In reply to comment #6)
> I think this is connected with Bug 345612 (as well as with 341595), and with
> XUL Cache (Preferences).

Michael, are you still seeing this?
Re #7: Stephen, I have just tried it with the 11 September Mac build, and it no longer crashes.

*** This bug has been marked as a duplicate of 341595 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.