Wrong coordinates of the menu items tooltiptext

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: mash, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

961 bytes, application/vnd.mozilla.xul+xml
Details
2.35 KB, image/png
Details
(Reporter)

Description

12 years ago
User-Agent:       Opera/9.00 (Windows NT 5.2; U; en)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

The position of menuitems tooltips is wrong calculated when mouse button is pressed.

Reproducible: Always

Steps to Reproduce:
0. Open testcase.
1. Click on the "push me" button and hold mouse button.
2. Move mouse pointer on any menuitem.
3. Tooltips coordinates is incorrect.
4. Don't release mouse button and open next level in menu ("test 1.5").
5. Move mouse pointer on any menuitem of "test 1.5"-menu.
6. Tooltips coordinates is more incorrect.
Actual Results:  
The tooltip is not at the mouse pointer.

Expected Results:  
The tooltip is at the mouse pointer.
(Reporter)

Comment 1

12 years ago
Created attachment 230438 [details]
Menu with tooltips

Simple testcase (menubutton with menuitems tooltips)
*** Bug 354737 has been marked as a duplicate of this bug. ***
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 07/09
Version: unspecified → 2.0 Branch
(Reporter)

Comment 4

11 years ago
Yes, still see.
rv:1.8.1.4 Gecko/20070515 Firefox/2.0.0.4
(Reporter)

Comment 6

11 years ago
Created attachment 268811 [details]
Screenshot

Screenshot. Hold mouse button, move mouse at "test 1.5.4" menuitem.
Nevermind, I see this on trunk too.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a6pre) Gecko/20070615 Minefield/3.0a6pre ID:2007061504
Whiteboard: CLOSEME 07/09
Version: 2.0 Branch → Trunk
(Reporter)

Comment 8

11 years ago
Confirm
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070618 Minefield/3.0a6pre

Updated

11 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout

Comment 9

10 years ago
Guys, are you able to reproduce this in the Firefox 3.0 releases? I'm not.
(Reporter)

Comment 10

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

Can't reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
--> WORKSFORME
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.