Thunderbird crashes at startup in [@nsTreeBodyFrame::GetIndentation]

RESOLVED WORKSFORME

Status

()

Core
XUL
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: stephend, Assigned: janv)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

12 years ago
I'm not sure when this regressed.

Smaug, I'm only cc:ing you because I think you might care or be able to help, not because I think you're the culprit... ;-)

Build ID: version 3 alpha 1 (20060724)

Steps to Reproduce:

1. Start up Thunderbird.
2. Crash, here (but note that this only happens _once_ per _build_, as I use the nightly auto-updater on trunk):

nsTreeBodyFrame::GetIndentation  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp, line 2357]
CallGetService  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/build/nsComponentManagerUtils.cpp, line 84]
NS_GetProxyForObject  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/proxy/src/nsProxyObjectManager.cpp, line 278]
nsThreadPool::ShutdownThread  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/threads/nsThreadPool.cpp, line 145]
nsThreadPool::Run  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/threads/nsThreadPool.cpp, line 217]
nsThread::ProcessNextEvent  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/threads/nsThread.cpp, line 483]
NS_ProcessNextEvent_P  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/build/nsThreadUtils.cpp, line 225]
nsThread::ThreadFunc  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/xpcom/threads/nsThread.cpp, line 251]
_PR_NativeRunThread  [e:/builds/tinderbox/Tb-Trunk/WINNT_5.0_Depend/mozilla/nsprpub/pr/src/threads/combined/pruthr.c, line 458]
kernel32.dll + 0xb50b (0x7c80b50b)
The stack trace looks strange. Does CallGetService use an already-delete-object.
Stephen, is this a new crasher?

CCing bsmedberg, he did something to ProxyObjects lately.
(Reporter)

Comment 2

12 years ago
Yeah, it's new.  Less than a week.  I thought it would be so obvious that I didn't file it right away, until I searched Bugzilla and found no reports.
(Reporter)

Comment 3

12 years ago
According to talkback, my/the first incident was with the 2006072205 build of TB.
Stephen, any chance that you could test that in which build this happens first?
Or is 2006072205 really the first build?
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> Or is 2006072205 really the first build?

I don't know anymore, as I went back to earlier builds (the 20th) and tested again there, but no crash for any build up until even today's.  I don't understand why this seemed to be a transient issue ;-( 

(Reporter)

Comment 7

11 years ago
I'm going to mark this as WFM; I can't reproduce using the current Thunderbird trunk on Windows Vista, and the reports from Talkback are not only Firefox-specific, but they have totally different line numbers.

The stack I _was_ seeing was consistently different from what few Talkback has.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
Crash Signature: [@nsTreeBodyFrame::GetIndentation]
You need to log in before you can comment on or make changes to this bug.