ecma_3/Date/15.9.5.6.js result: FAILED type: browser - Nipigone Time zone

RESOLVED DUPLICATE of bug 1089745

Status

()

RESOLVED DUPLICATE of bug 1089745
13 years ago
a year ago

People

(Reporter: bc, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
This happens only on the seneca Linux CentOS boxes with timezone EST. Happens on all branches.

15.9.5.6 Date.prototype.toLocaleDateString()
typeof (now.toLocaleDateString()) = string   PASSED!
Date.prototype.toLocaleDateString.length = 0   PASSED!
(Date.parse(now.toLocaleDateString()) - (midnight(now)).valueOf()) == 0 = false  FAILED! expected: true
Date.parse(Wed Dec 31 1969 19:00:00 GMT-0500 (EST)).toLocaleDateString()) = 48142800000  FAILED! expected: -68400000
Date.parse(Wed Dec 31 1969 14:00:00 GMT-0500 (EST)).toLocaleDateString()) = 48142800000  FAILED! expected: -68400000
Date.parse(Sun Dec 31 1899 19:00:00 GMT-0500 (EST)).toLocaleDateString()) = -2160849600000  FAILED! expected: -2209057200000
Date.parse(Mon Jan 01 1900 00:00:00 GMT-0500 (EST)).toLocaleDateString()) = -2208970800000   PASSED!
Date.parse(Fri Dec 31 1999 19:00:00 GMT-0500 (EST)).toLocaleDateString()) = 994910400000  FAILED! expected: 946616400000
Date.parse(Sat Jan 01 2000 00:00:00 GMT-0500 (EST)).toLocaleDateString()) = 946702800000   PASSED!
Date.parse(Mon Feb 28 2000 19:00:00 GMT-0500 (EST)).toLocaleDateString()) = 1017723600000  FAILED! expected: 951714000000
Date.parse(Mon Feb 28 2000 18:59:59 GMT-0500 (EST)).toLocaleDateString()) = 1017723600000  FAILED! expected: 951714000000
Date.parse(Tue Feb 29 2000 00:00:00 GMT-0500 (EST)).toLocaleDateString()) = 1020312000000  FAILED! expected: 951800400000
Date.parse(Fri Dec 31 2004 19:00:00 GMT-0500 (EST)).toLocaleDateString()) = 1152676800000  FAILED! expected: 1104469200000
Date.parse(Fri Dec 31 2004 18:59:59 GMT-0500 (EST)).toLocaleDateString()) = 1152676800000  FAILED! expected: 1104469200000
Date.parse(Sat Jan 01 2005 00:00:00 GMT-0500 (EST)).toLocaleDateString()) = 1104555600000   PASSED!
(Reporter)

Comment 1

13 years ago
Note 1.8 and trunk also failed in the shell. Not sure if 1.8.0.5 actually passed in the shell or it is test fubar.
(Reporter)

Comment 2

13 years ago
ditto js1_5/Regress/regress-58116.js. 
(Reporter)

Comment 3

11 years ago
This was due to the timezone being set to Nipigon in Ontario.
Blocks: 285663
Summary: ecma_3/Date/15.9.5.6.js result: FAILED type: browser → ecma_3/Date/15.9.5.6.js result: FAILED type: browser - Nipigone Time zone
Assignee: general → nobody
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089745
You need to log in before you can comment on or make changes to this bug.