Cannot display context menu for bookmarks using keyboard

RESOLVED DUPLICATE of bug 212750

Status

()

Firefox
Disability Access
RESOLVED DUPLICATE of bug 212750
12 years ago
12 years ago

People

(Reporter: Wayne DeAngelo, Unassigned)

Tracking

({access})

Trunk
x86
Windows XP
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Test environment: Bon Echo Nightly Build 20070724
Test done on IBM T42 ThinkPad.

Description:  

You cannot display the context menu for bookmarks using the keyboard.  The standard Windows keystroke for displaying a context menu is Shift+F10, but that does not work.   For example, to delete a bookmark, a blind or mobility impaired user is forced to use the "Organize bookmarks" dialog.  A sighted person using a mouse has much more usable option of right clicking on the bookmark and selecting "Delete" from the context menu.  

Steps to Reproduce:
1. Make sure at least one bookmark is found in the Bookmarks menu pulldown
2. Press Alt+B to display bookmarks pulldown
3. Arrow down to a bookmark in the pulldown menu
4. Press Shift+F10
5. Instead of displaying the Context menu, the bookmark menu disappears.

Expected Result:
When Shift+F10 is pressed, the context menu should be displayed.  If you right-click the mouse on the bookmark, you will see the context menu.  (BTW, this works as expected when using Internet Explorer.)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 212750 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.