Provide a browser.tabs.tabMaxWidth

RESOLVED FIXED in Firefox 3 alpha5

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: emfficc, Assigned: dao)

Tracking

Trunk
Firefox 3 alpha5
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.2

There is a browser.tabs.tabMinWidth, but not a browser.tabs.tabMaxWidth.
Previously, I always used a userChrome.css for a tab fixed width. Without that, the tabs fill up the width of the tab strip which is inconvenient for various reasons. e.g. you need to chase close buttons which have different distances.
And another reason is that there is no space to doubleclick on the tab strip when you have 6 tabs open.
In the latest test version of BonEcho however, the userChrome code doesn't work anymore.
I tried extensions like TabControl, but it also overlays other tab functions that are better in BonEcho.
So please provide a pref to set a max width, or change the code so that the userChrome works again.

Reproducible: Always

Steps to Reproduce:
1. Open tabs one by one
Actual Results:  
They fill up the tab strip

Expected Results:  
Every tab should have the same size that I can specify in about:config

Comment 1

11 years ago
This sounds like unnecessary pref bloat. -> WONTFIX

If you don't want to chase close buttons, set the pref browser.tabs.closeButtons to 3 (i.e. the same as for Firefox 1.5). If you want space to double-click, add a rule similar to the following to your userChrome.css:

.tabbrowser-tabs scrollbox > box { padding-right: 20px !important; }

Otherwise to lower the maximal tab width, add the following lines to your userChrome.js [1]:

eval("gBrowser.addTab = " + gBrowser.addTab.toString().replace("maxWidth = 250", "maxWidth = 140"));
Array.forEach(gBrowser.tabContainer.childNodes, function(aTab) { aTab.maxWidth = 140; });

The same could be achieved by any tabbed browsing extension.

[1] http://forums.mozillazine.org/viewtopic.php?t=397735
(Reporter)

Comment 2

11 years ago
This is a very complicated extension that I can't recommendate to my dad...
He could change it as well in the tabbrowser.xml file with the same effort.
I think it should be a normal option to be able to change the width of a tab.
Flags: blocking-firefox2?

Comment 3

11 years ago
Obviously that specific extension isn't for your dad. But neither is the userChrome.css you've applied so far. And neither is changing a hidden pref. Your dad is supposed to either simply use the defaults (why shouldn't he?) or get himself an extension to do this for him.

My point was that it's very easy for extensions to achieve the effect without a separate pref. Since an extension would be required anyway, there's nothing more Firefox must provide. Thus: WONTFIX.
This isn't _that_ unreasonable, we have a pref for minWidth already, what's the overhead there?  This is worth discussing, at least, but we wouldn't ever block on adding a hidden pref.
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox2? → blocking-firefox2-

Comment 5

11 years ago
Now that we have the ability to scroll through the tab overflow, I think creating this option has new significance.  Now people aren't as worried about how many tabs are visible on the screen at once, so they would now like to "turn off" the tab resizing by making the tab width a constant value.  This has the added benefit of allowing for the the close buttons to be equally spaced, so that you can close a sequence of successive tabs without moving your mouse.  

The only way to currently do this is to set browser.tabs.tabMinWidth to 250, which is the hard coded maximum width.  However, this is too wide for many people's liking, regardless of the ability to now scroll through the overflow. (Only 5 tabs are visible at one time with this width setting at 1280x1024!)

The only other problem that needs to be rectified so that the close buttons don't have to be chased, is to create an option to allow for the new scroll arrows to be set to always be visible, never be visible, or the current setting, visible only when there is overflow.  I will create an enhancement request for that soon, if someone doesn't beat me to it first!

Comment 6

11 years ago
i think this is a good idea. 
Summary: Provide a browser.tabs.tabMaxWidth for BonEcho → Provide a browser.tabs.tabMaxWidth
(Assignee)

Comment 7

10 years ago
Created attachment 264871 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #264871 - Flags: review?(mano)
Comment on attachment 264871 [details] [diff] [review]
patch

r=mano, please post a patch without the bogus |cvs diff| lines.
Attachment #264871 - Flags: review?(mano) → review+
(Assignee)

Comment 9

10 years ago
Created attachment 264930 [details] [diff] [review]
patch
Attachment #264871 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [checkin needed]
Checking in browser/app/profile/firefox.js;
/cvsroot/mozilla/browser/app/profile/firefox.js,v  <--  firefox.js
new revision: 1.177; previous revision: 1.176
done
Checking in toolkit/content/widgets/tabbrowser.xml;
/cvsroot/mozilla/toolkit/content/widgets/tabbrowser.xml,v  <--  tabbrowser.xml
new revision: 1.229; previous revision: 1.228
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox 3 alpha5
Version: unspecified → Trunk
(Assignee)

Updated

10 years ago
Blocks: 305267
You need to log in before you can comment on or make changes to this bug.