All history is lost on a sporadic basis, probably due to forced closings

RESOLVED DUPLICATE of bug 242207

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 242207
11 years ago
9 years ago

People

(Reporter: Robert Lindsay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Very,very, very long-term problem. History has NEVER worked propertly in FF. On a sporadic basis, but usually around maybe once a month or so, the history file (and corresponding location bar history, is wiped out. In general, it seems to be due to hard closings (the Win2K equivalent of a crash), or possibly due to an overloaded, highly unstable browser. Since this problem is sporadic, it may be hard to fix. But this is a very bad problem because it has been extant in ALL Firefox versions. At some point, the history file is simply deleted. Then, you lose all your url-history, which is annoying since I don't use bookmarks. Opera, by contrast, rarely or never has this problem.

Reproducible: Sometimes

Steps to Reproduce:
1. Use Firefox for a while (weeks)
2. Develop an unstable browser or hard close FF


Actual Results:  
FF erases the entire history file.

Expected Results:  
1. Use FF for months at a time.
2. Rarely, if ever, erase history file.

Problem is very sporadic but very longstanding. It has been present from the earliest versions to the latest. It's bug that has been in FF for years now.
This problem should be fixed by bug 242207, which which will be in Firefox 1.5.0.5 when it is released in the next day or so. I'm going to dupe against that bug, but please reopen this one if you still have problems with 1.5.0.5.

*** This bug has been marked as a duplicate of 242207 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)

Thank you. I searched the whole db but I could not find #242207, though that is clearly the same *nasty* bug. Sorry to file a dupe. I did search.

Updated

9 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.