In the search bar, scrolling the mouse wheel should switch the engine

VERIFIED FIXED in Firefox 3 beta2

Status

()

Firefox
Search
--
enhancement
VERIFIED FIXED
11 years ago
6 years ago

People

(Reporter: tommyjb, Assigned: Michael Ventnor)

Tracking

Trunk
Firefox 3 beta2
Points:
---
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

11 years ago
(This is based on StringCheesian's proposal on f.m.o.)

1. This would be very handy for switching the engine for 'Search <selected engine> for <selected text>' searches (see bug 203959).
2. This would probably be more discoverable and more memorable than Ctrl+Up/Ctrl+Down -- and perhaps more convenient as well, for those who focus the search bar with the mouse (rather than using Ctrl+K).

Perhaps this would apply only to the engine icon itself.

Updated

11 years ago
Component: Search → Search
Product: Firefox → Core
Can't seem to find a simmilar bug after a few searches so marking this as new... if anyone else finds one please re-mark.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Search → Search
Product: Core → Firefox
Hardware: PC → All
(Assignee)

Comment 2

11 years ago
Created attachment 231744 [details] [diff] [review]
Patch

This works whenever the mouse is over the search bar. I'm wondering whether this needs a UI-review first, though.
Attachment #231744 - Flags: ui-review?(beltzner)
What happens to mousewheel events when the typeahead drop-down is showing? Do they still get sent to that scrollbar?
(Assignee)

Comment 4

11 years ago
(In reply to comment #3)
> What happens to mousewheel events when the typeahead drop-down is showing? Do
> they still get sent to that scrollbar?
> 

Do you mean the drop down with search history and suggestions? The mousewheel still controls the scrollbar, and the engine doesn't change. The engine only changes when the mouse is over the search logo, search field, or submit button.
(Reporter)

Comment 5

11 years ago
This would be particularly nice with the new search-engine button that landed on the branch a few days ago.  :)
(Assignee)

Updated

11 years ago
Attachment #231744 - Flags: ui-review?(beltzner)
(Assignee)

Updated

11 years ago
Attachment #231744 - Flags: review?(gavin.sharp)
(Assignee)

Updated

11 years ago
Attachment #231744 - Flags: ui-review?(beltzner)
(Assignee)

Comment 6

11 years ago
Created attachment 240912 [details] [diff] [review]
Updated patch

Changed the patch to keep it up-to-date with changes on the trunk.
Attachment #231744 - Attachment is obsolete: true
Attachment #240912 - Flags: ui-review?(beltzner)
Attachment #240912 - Flags: review?(gavin.sharp)
Attachment #231744 - Flags: ui-review?(beltzner)
Attachment #231744 - Flags: review?(gavin.sharp)
Comment on attachment 240912 [details] [diff] [review]
Updated patch

>Index: search.xml

>+      <handler event="DOMMouseScroll"
>+               phase="capturing"
>+               action="this.selectEngine(event, (event.detail > 0));"/>
>+      </handlers>
>     </handlers>

This extra </handlers> makes this not work, r=me with this removed.
Attachment #240912 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 8

11 years ago
Created attachment 240983 [details] [diff] [review]
Fix bad copy and paste

Yikes, had a bad copy and paste in that one. Sorry! r=gavin.
Attachment #240912 - Attachment is obsolete: true
Attachment #240983 - Flags: ui-review?(beltzner)
Attachment #240983 - Flags: review+
Attachment #240912 - Flags: ui-review?(beltzner)
(Assignee)

Updated

11 years ago
Attachment #240983 - Flags: ui-review?(beltzner)
(Assignee)

Updated

11 years ago
Attachment #240983 - Flags: ui-review?(beltzner)
(Assignee)

Updated

11 years ago
Attachment #240983 - Flags: ui-review?(beltzner)
(Assignee)

Updated

11 years ago
Attachment #240983 - Flags: ui-review?(beltzner)
(Assignee)

Updated

11 years ago
Attachment #240983 - Flags: ui-review?(beltzner)
Assignee: nobody → ventnor.bugzilla
(Assignee)

Updated

11 years ago
Attachment #240983 - Flags: ui-review?(beltzner)
Comment on attachment 240983 [details] [diff] [review]
Fix bad copy and paste

mconnor's concerned that people might accidentally switch their search engine with this, and not understand how to get it back, but I'm less worried about that edge case and think this will help more than hinder.

We should watch out for bug and anecdotal reports of his concern, though.
Attachment #240983 - Flags: ui-review?(beltzner) → ui-review+
Attachment #240983 - Flags: approval1.9?

Updated

10 years ago
Attachment #240983 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

10 years ago
Keywords: checkin-needed
Checking in browser/components/search/content/search.xml;
/cvsroot/mozilla/browser/components/search/content/search.xml,v  <--  search.xml
new revision: 1.109; previous revision: 1.108
done
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M10
Flags: in-litmus?
Litmus Triage team: Tomcat will create a testcase for this
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2pre) Gecko/2007120704 Minefield/3.0b2pre also created a litmus testcase of this.
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
Depends on: 410603

Comment 13

10 years ago
This was changed to Cmd+scroll in bug 410603.

Comment 14

9 years ago
For consistency sake can this be extended to the search context menu? Is that another bug?
I used to rely on this add-on on the past https://addons.mozilla.org/en-US/firefox/addon/3696 and I'm gld this is being integrated.

Updated

6 years ago
Duplicate of this bug: 675186
You need to log in before you can comment on or make changes to this bug.