Live bookmarks fails to load on startup if using proxy with authentication

RESOLVED DUPLICATE of bug 266348

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 266348
12 years ago
12 years ago

People

(Reporter: Pradeep Kumar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060526 BonEcho/2.0a3

The live bookmarks show the popup "Live bookmark failed to load" after starting firefox

Reproducible: Always

Steps to Reproduce:
1. You need to behind a proxy which requires authentication. In my case Squid. Have firefox configured correctly with the proxy settings.
2. Add a few live bookmarks for testing.
3. Close and restart firefox
4. Check the live bookmarks

Actual Results:  
All the live bookmarks report as "failed to load". It loads only if u manually right click each one of them and say "reload live bookmark".

Expected Results:  
At startup Should have prompted me with the proxy authentication dialog and proceeded to load the live bookmarks.
A much better way(less forceful) would be to wait for the user to dropdown(or mouseover) a live bookmark to look at the posts and then challenge the user if required and after successful authentication start loading all live bookmarks.

*** This bug has been marked as a duplicate of 266348 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.