attachment links should include a view source link

RESOLVED WONTFIX

Status

()

Bugzilla
Attachments & Requests
--
enhancement
RESOLVED WONTFIX
12 years ago
2 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
jesse has a tendency to include testcases that crash, so i have a number of problems.

2. clicking an attachment link can easily be fatal, which is bad, since i might want to view the source of the link. but firefox doesn't make this easy

steps:
1. pick any bug where jesse has posted a testcase that will crash your gecko
2. carelessly click on the testcase
3. click view source

ideal exected results:
instead of clicking the attachment link you click a 'view attachment source' link and it takes you to a page that *doesn't* kill your gecko

actual results:
your browser crashes at step 2 before you find out why

steps to fix:
add a 'view attachment source' link

Note: i'm not sure i care if this goes into bugzilla product, but given that we've added some silly hack to the url field specifically because of people like jesse, i don't think it's unreasonable for this to go into bugzilla core instead of bmo. no matter what, i want this for bmo.

Comment 1

12 years ago
I wrote a Greasemonkey script that does something like this:

http://www.squarefree.com/userscripts/bug-attachment-source.user.js

Timeless is trying to avoid using Greasemonkey, though.
QA Contact: myk → reed
Assignee: justdave → attach-and-request
Component: Bugzilla: Other b.m.o Issues → Attachments & Requests
OS: Windows XP → All
Product: mozilla.org → Bugzilla
QA Contact: reed → default-qa
Hardware: PC → All
Target Milestone: --- → Bugzilla 3.2
Version: other → 2.23.4

Comment 2

10 years ago
Bugzilla 3.2 is now frozen. Only enhancements blocking 3.2 or specifically approved for 3.2 may be checked in to the 3.2 branch. If you would like to nominate your enhancement for Bugzilla 3.2, set the "blocking3.2" flag to "?". Then, either the target milestone will be changed back, or the blocking3.2 flag will be granted, if we will accept this enhancement for Bugzilla 3.2.

This particular bug has not been touched in over eight months, and thus is being retargeted to "---" instead of "Bugzilla 4.0". If you believe this is a mistake, feel free to retarget it to Bugzilla 4.0.
Target Milestone: Bugzilla 3.2 → ---

Updated

7 years ago
Duplicate of this bug: 626331

Comment 4

2 years ago
The Details page already display the source code of HTML pages, for security reasons.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.