Incorrect Icon displayed for RSS Feeds in overflow region onthe bookmarks toolbar

RESOLVED FIXED in Firefox 2 beta2

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: LonelyBob, Assigned: Mark Mentovai)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2 beta2
PowerPC
Mac OS X
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2 (MultiLang)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060728 BonEcho/2.0b1

When an RSS Feed is in the overflow region on the bookmarks toolbar the Folder icon displays instead of the RSS Feed icon. Reproduced on 2 OSX systems.
Seems to not be reproduced on windows based on feedback in IRC channel.
see screenshot- Direct link to screenshot- http://img373.imageshack.us/img373/6605/firefox2snapshot20060729005944ud6.png
Indirect link to screenshot- http://img373.imageshack.us/my.php?image=firefox2snapshot20060729005944ud6.png
Look at the NYT > Media and Advertising RSS Feed icon in this screenshot


Reproducible: Always

Steps to Reproduce:
1. Add some RSS feeds to the bookmarks toolbar
2. Resize you browser width so that an RSS feed is off the Browser display.
3. Click on the >> to view the RSS Feeds on the overflow region.
4. Check that the icons are correct

Actual Results:  
RSS Feed displays with Folder icon instead of RSS Feed icon.

Expected Results:  
RSS Feed icon is displayed for each RSS Feed.

Direct link to screenshot- http://img373.imageshack.us/img373/6605/firefox2snapshot20060729005944ud6.png
Indirect link to screenshot- http://img373.imageshack.us/my.php?image=firefox2snapshot20060729005944ud6.png
Look at the NYT > Media and Advertising RSS Feed icon in this screenshot
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Updated

11 years ago
OS: Mac OS X 10.3 → Mac OS X 10.4
This seems to work fine on windows:
http://www.wargers.org/mozilla/Clipboard01.gif
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060728 BonEcho/2.0b1
OS: Mac OS X 10.4 → Mac OS X 10.3
Confiming. I see the same thing as the reporter using Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060728 BonEcho/2.0b1.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

11 years ago
Easy theme fix, I can do this.  This also affects the display whenever a livemark is in a folder on the bookmarks bar, and with the patch in bug 46177, any time a livemark is in the main bookmarks menu.

(P.S. Hey, Martijn, in your Windows screen shot, the entries in the livemark have plain doc icons instead of the livemark doc icons we have on the Mac.)

(P.P.S. I can't drag livemarks and folders around in the bookmark toolbar at all because any clicks open the submenu popup.  I don't have easy access to a win32/gtk box now - do you see this bug there too, or is it Mac-specific?)
(Reporter)

Updated

11 years ago
OS: Mac OS X 10.3 → Mac OS X 10.4
(Assignee)

Updated

11 years ago
Assignee: nobody → mark
OS: Mac OS X 10.4 → Mac OS X 10.2
Target Milestone: --- → Firefox 2 beta2
(Assignee)

Comment 4

11 years ago
A patch for this is included in the latest (v3) patch on bug 46177.
(Assignee)

Comment 5

11 years ago
Fix checked in along with bug 46177 on the trunk and 1.8 branch for 1.8.1b2.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.