Iframe inherits parent background properties.

RESOLVED DUPLICATE of bug 154957

Status

()

--
minor
RESOLVED DUPLICATE of bug 154957
12 years ago
12 years ago

People

(Reporter: Mentaloid, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5

Pages in an iframe with no bgcolor specified in the body or assigned via css will inherity the parent documents bgcolor. The parents bgcolor may be specified by either CSS body { background-color: rgb(127,127,127);} or <body bgcolor=grey>.

I believe this isn't really supposed to be the way it works as the pages in an iframe aren't supposed to inherit anything from the parent. 

Reproducable with release versions of firefox on winXP, The newest daily build (mozilla/5.0 (windows; u; windows nt 5.1; en-us; rv:1.9a1) gecko/20060728 minefield/3.0a1) as well as latest release of mozilla & firefox for linux (tested on various flavors of linux, all x86 based).

Reproducible: Always

Steps to Reproduce:
1. Load URL above.
2. Peer deeply into the screen.
3. Read the information on the URL supplied.

Actual Results:  
Background color in iframe was inherited from parent.

Expected Results:  
Background color in iframe to be default.
Bug 154957 explains why it is done this way.

*** This bug has been marked as a duplicate of 154957 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
Oppsie, didn't see that one. Sorry for the dup!
*** Bug 346433 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.