Closed Bug 346560 Opened 18 years ago Closed 18 years ago

Restart confirmation dialog prompting while typing may lead to data loss

Categories

(Toolkit :: Application Update, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 334767

People

(Reporter: teoli, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.8.1b1) Gecko/20060729 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.8.1b1) Gecko/20060729 BonEcho/2.0b1

If somebody is having autoupdate on (which is the default) and the confirmation dialog for restart pop-ups while his typing it may inadvertently leads to an unwilling restart (by pressing one of the shortcuts for restart).

We get several of these guys on the support forums after each update. They are usually quite angry, having lost some data (most of the time a long e-mail typed in an webmail appl).

After some study there are two use-cases leading to this problems.

1) 2-finger typists: they usually don't look at the screen while typing but on the keyboard. They don't notice the popup and accidentally press the shortcut for restart (r or space).
2) 10-finger typists copying a text: they look at the text not at the screen. They may also not notice the popup.

Reproducible: Always

Steps to Reproduce:
1.Type in a textarea or an input field
2.Popup for restart after an automatic software update
3.Continue typing as in the textarea->it will restart.




Possible solution: prevent this popup to show while the focus is in an INPUT field or a TEXTAREA. From a certain point of view, when the user is typing we are quite sure that he does not want to restart Firefox at once, he wants to finish what his doing.

Note: I've put severity as enhancement, even if it leads to data loss.
howdy y'all,

[1] my ff & tb info
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Firefox/1.5.0.5 - Build ID: 2006071912

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.5) Gecko/20060719 Thunderbird/1.5.0.5 - Build ID: 2006071912

[2] a mozillazine thread on this subject
Proposal: New options for Updates GUI
- http://forums.mozillazine.org/viewtopic.php?t=445307

[3] from that thread is what i consider the best solution so far.
http://forums.mozillazine.org/viewtopic.php?p=2400654#2400654
"
The restart button should be delayed for 3 seconds, just like the XPInstall button. That's the easiest solution.
"

take care,
lee

There is already a delay of two seconds before enabling the restart button (bug 311288), but as the reporter points out this isn't sufficient if the user isn't watching the screen.

*** This bug has been marked as a duplicate of 334767 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.