Closed Bug 346688 Opened 15 years ago Closed 15 years ago

crash in nsObjectFrame::Instantiate(), mInstanceOwner was null

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 136927

People

(Reporter: moco, Unassigned)

References

()

Details

crash in nsObjectFrame::Instantiate(), mInstanceOwner was null

here is my stack:

>	gklayout.dll!nsObjectFrame::Instantiate(const char * aMimeType=0x04c40ed8, nsIURI * aURI=0x057471e0)  Line 1339 + 0x24 bytes	C++
 	gklayout.dll!nsObjectLoadingContent::Instantiate(const nsACString_internal & aMIMEType={...}, nsIURI * aURI=0x057471e0)  Line 1349 + 0x1a bytes	C++
 	gklayout.dll!nsAsyncInstantiateEvent::Run()  Line 140 + 0x1e bytes	C++
 	xpcom_core.dll!nsThread::ProcessNextEvent(int mayWait=0x00000001, int * result=0x0012fc34)  Line 483	C++
 	xpcom_core.dll!NS_ProcessNextEvent_P(nsIThread * thread=0x00b3a180, int mayWait=0x00000001)  Line 225 + 0x16 bytes	C++
 	gkwidget.dll!nsBaseAppShell::Run()  Line 153 + 0xc bytes	C++
 	tkitcmps.dll!nsAppStartup::Run()  Line 171 + 0x1c bytes	C++
 	xul.dll!XRE_main(int argc=0x00000001, char * * argv=0x00b381c0, const nsXREAppData * aAppData=0x004036b0)  Line 2387 + 0x25 bytes	C++
 	firefox.exe!main(int argc=0x00000001, char * * argv=0x00b381c0)  Line 61 + 0x13 bytes	C++
 	firefox.exe!__tmainCRTStartup()  Line 586 + 0x19 bytes	C
 	firefox.exe!mainCRTStartup()  Line 403	C
 	kernel32.dll!7c816d4f() 	
 	[Frames below may be incorrect and/or missing, no symbols loaded for kernel32.dll]	
 	kernel32.dll!7c8399f3() 	
 	xpcom_core.dll!nsExceptionService::RegisterExceptionProvider(nsIExceptionProvider * provider=0x00530022, unsigned int errorModule=0x00730079)  Line 264	C++

I'm using my own, windows xp debug trunk build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060725 Minefield/3.0a1

I think it was http://www.thedittybopsbiketour.blogspot.com/ that caused the crash.

here's my console, in case this helps:

For application/x-shockwave-flash found plugin C:\WINDOWS\system32\Macromed\Flas
h\NPSWF32.dll
WARNING: recurring into frame construction: 'mPresContext->mLayoutPhaseCount[eLa
youtPhase_FrameC] == 0', file c:\builds\trunk\mozilla\layout\base\nsPresContext.
h, line 846
###!!! ASSERTION: about to crash due to bug 136927: '!mInstantiating', file c:/b
uilds/trunk/mozilla/layout/generic/nsObjectFrame.cpp, line 487
WARNING: recurring into frame construction: 'mPresContext->mLayoutPhaseCount[eLa
youtPhase_FrameC] == 0', file c:\builds\trunk\mozilla\layout\base\nsPresContext.
h, line 846
WARNING: recurring into frame construction: 'mPresContext->mLayoutPhaseCount[eLa
youtPhase_FrameC] == 0', file c:\builds\trunk\mozilla\layout\base\nsPresContext.
h, line 846
WARNING: NS_ENSURE_TRUE(mOwner) failed: file c:/builds/trunk/mozilla/layout/gene
ric/nsObjectFrame.cpp, line 2393
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file c:/builds/trunk/mozilla/l
ayout/generic/nsObjectFrame.cpp, line 1685
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file c:/builds/trunk/mozilla/m
odules/plugin/base/src/ns4xPluginInstance.cpp, line 982
###!!! ASSERTION: re-cache of attrs/params not implemented! use the DOM node dir
ecty instead: '((mNumCachedAttrs + mNumCachedParams) == 0) && !mCachedAttrParamN
ames', file c:/builds/trunk/mozilla/layout/generic/nsObjectFrame.cpp, line 2285
WARNING: NS_ENSURE_TRUE(mOwner) failed: file c:/builds/trunk/mozilla/layout/gene
ric/nsObjectFrame.cpp, line 2286
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file c:/builds/trunk/mozilla/l
ayout/generic/nsObjectFrame.cpp, line 1993
WARNING: NS_ENSURE_TRUE(peer) failed: file c:/builds/trunk/mozilla/modules/plugi
n/base/src/ns4xPluginInstance.cpp, line 969
###!!! ASSERTION: re-cache of attrs/params not implemented! use the DOM node dir
ecty instead: '((mNumCachedAttrs + mNumCachedParams) == 0) && !mCachedAttrParamN
ames', file c:/builds/trunk/mozilla/layout/generic/nsObjectFrame.cpp, line 2285
WARNING: NS_ENSURE_TRUE(mOwner) failed: file c:/builds/trunk/mozilla/layout/gene
ric/nsObjectFrame.cpp, line 2286
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed: file c:/builds/trunk/mozilla/l
ayout/generic/nsObjectFrame.cpp, line 1700
I haven't been able to reproduce this yet, but after re-reading my console, I see:

###!!! ASSERTION: about to crash due to bug 136927: '!mInstantiating', file
c:/builds/trunk/mozilla/layout/generic/nsObjectFrame.cpp, line 487

marking as duplicate of bug #136927

*** This bug has been marked as a duplicate of 136927 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.