Leaves "drag" mouse cursor as if the History Sidebar would accept dragged text.

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Maxim Radugin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060731 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060731 BonEcho/2.0b1

Leaves "drag" mouse cursor as if the History Sidebar would accept dragged text.

Reproducible: Always

Steps to Reproduce:
1. Open History Sidebar.
2. Select some text on the web page.
3. Drag it to the History Sidebar.

Actual Results:  
Leaves "drag" mouse cursor as if the History Sidebar would accept dragged text.

Expected Results:  
Should change mouse pointer to "unavailable" cursor.

Comment 1

12 years ago
OK, great point!  However, it is important that the icon remains a "drag" icon on the Search: text box, because that is a valid place to drag text.
Status: UNCONFIRMED → NEW
Ever confirmed: true
see bug #346750, which is a duplicate of this bug.

I plan on fixing it for the history-sidebar-built on top of the places backend, but I haven't figured it out yet.

note, the places tree (http://lxr.mozilla.org/seamonkey/source/browser/components/places/content/tree.xml) has it's own drag and drop observer.
Assignee: nobody → sspitzer
Target Milestone: --- → Firefox 3
> see bug #346750, which is a duplicate of this bug.

oops, I meant bug #358838
Status: NEW → ASSIGNED
Depends on: 356174
*** Bug 358838 has been marked as a duplicate of this bug. ***
sorry for the bug spam, re-assigning bugs back to default owner if I'm not working actively on them.
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
Target Milestone: Firefox 3 → ---
WFM
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090108 Shiretoko/3.1b3pre
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.