No shortcut for Highlight All in quickfind

RESOLVED WONTFIX

Status

()

Toolkit
Find Toolbar
--
minor
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: Bamm Gabriana, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
I have the "Begin finding when you begin typing" option enabled. This has truly revolutionized the way users find. It may be different at first, but once you get used to it there is no turning back, just like tabs.

In older Firefox versions, I could just type the word and then hit Alt+A to highlight every occurance. This is because "Highlight all" has the letter "a" as its accesskey. Now that this button is gone, it becomes impossible to highlight all by just FAYT, that is, without pressing Ctrl+F.

There is no problem with Next and Previous, because these can be accessed by F3 and Shift+F3. But there is no keyboard shortcut for "Highlight all", at least none that I know of.

I consider this loss of functionality a regression due to the change in the Find toolbar. This could be fixed by adding a keyboard binding.

Perhaps Ctrl+Shift+F3 would be a good binding? The old Alt+A should also work if the Quick Find toolbar is open, even if it doesn't have the button anymore.
Blocks: 337654
Keywords: regression
OS: Windows Server 2003 → All
Hardware: PC → All

Comment 1

12 years ago
How can this unfixed bug block a fixed bug (bug 337654)? :-\

Comment 2

12 years ago
To clarify somewhat, this bug appears to be asking for the 'highlight all' shortcut (alt-a on win, ctrl-a on mac) to work with quickfind as well as regular old find. 

On a related note, and especially if we do this, the highlight all shortcut should work to enable/disable the highlight even when the findbar isn't shown. Right now, if you open the find bar, find for something, turn on highlighting with alt-a, and then close the find bar, there is no way to turn the highlight off again without reopening the findbar. 
Severity: normal → minor
Keywords: regression
Summary: Unable to "Highlight all" when using FAYT → No shortcut for Highlight All in quickfind

Comment 3

12 years ago
As comment 0 states, accel+a is a keyboard accessor for a button, not a shortcut directly to "highlight all".  The button is not there in Quick Find mode, so the keyboard shortcut should not work.

Adding a shortcut for "highlight all" is troublesome.  As comment 2 states, any such shortcut should work regardless of whether the find bar is visible; but then the shortcut cannot be accel+a.  Furthermore, this is of questionable utility.  If highlighting is useful, we should just do it.  If not, there's no reason it needs to be exposed beyond the find bar.

Therefore I believe the correct fix here is for both find modes to simply auto-highlight all matches, which is bug 342101.

An alternate fix is to suggest, as an RFE, that turning on typeaheadfind autostart should make typing trigger the find bar rather than the quick find bar.  This is what I've discussed in bug 337654 comment 38 and bug 337654 comment 40.  This would mean users who turn on the autostart pref get "fast access to find", which is I think what most people (including the original filer) take the bug to mean.

In the meantime, the Quick Find bar is not designed to serve the same function as "find".  Hitting ctrl-f when you need to get at the heavier-weight find bar is the workaround.  That is, start typing, and when you want to highlight, hit ctrl-f alt-a.
No longer blocks: 337654
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> This is what I've discussed in bug 337654 comment 38 and bug 337654
> comment 40.  This would mean users who turn on the autostart pref get "fast
> access to find", which is I think what most people (including the original
> filer) take the bug to mean.

Initially I also wanted the typeahead to trigger the Find bar rather than the Quick Find, but since that will not happen, what we need now is to restore lost functionality due to the change.

> In the meantime, the Quick Find bar is not designed to serve the same function
> as "find".  Hitting ctrl-f when you need to get at the heavier-weight find bar
> is the workaround.  That is, start typing, and when you want to highlight, hit
> ctrl-f alt-a.

I did mention that in Comment 0 that we are now forced to do a Ctrl+F workaround just to highlight, whereas in the past this was not necessary. That's why I called this a regression. It was possible before, but not anymore.

The suggestion to highlight all matches as you type could be useful but quite distracting, and we will still need a keyboard shortcut to remove the highlight. So wouldn't it be logical to have a keyboard shortcut to turn it on also?

We must be consistent. Next and Previous have shortcuts (with or without the Quick Find!), so it's logical that Highlight would have its own shortcut too.

Even if we do get rid of Quick Find (and trigger the Find bar during TAF), we still need a keyboard shortcut. It is a keyboard action to type, and we don't want people to reach for the mouse just to click Highlight all. I still suggest Ctrl+Shift+F3. No need for a workaround if there's a simpler solution for the user.

That is, type your word to get to the location of the first match, then hit a keyboard shortcut to highlight all.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 5

12 years ago
Bamm: Please do not reopen bugs after the module owner has marked them as WONTFIX. I agree that there is some value in potentially allowing the Highlight All shortcut key to function in quickfind, but this is a UI decision that should be handled in the broader context of the quickfind/Type-Ahead-Find UI. Your views on this issue have been stated, and I assure you that they will be taken into consideration when future changes are made to quickfind. This is not a regression, as quickfind functions according to specification. 

Turning on regular find rather than quickfind for typeaheadfind autostart (as pkasting suggests in the third paragraph of his comment) is a different bug, and it should be filed as such if it has not been filed already. 

Back to ->WONTFIX. 
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

12 years ago
Sorry for that. If pkasting's suggestion to turn on regular find is done, that would be great. Keeping this WONTFIX.
(Reporter)

Comment 7

12 years ago
I suggest we mark this as a duplicate of Bug 347259 assigned to pkasting, since that solution has also been mentioned in Comment 3. That bug will automatically solve this.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.