Closed Bug 346854 Opened 16 years ago Closed 10 years ago

DOM Inspector, Inspect URL dialog accessibility issues

Categories

(Other Applications :: DOM Inspector, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: deangelo, Assigned: foss)

References

Details

(Keywords: access)

Attachments

(1 file, 1 obsolete file)

Test environment:
   Windows XP, Firefox 2 (Bon Echo) build 20060731, Microsoft Inspect Objects

The text entry field in the Inspect URL dialog has no associated MSAA Name property.  The MSAA Name should contain the label text for the field, which says “Enter a URL:”.

Steps to recreate:
1. Start Inspect Objects
2. In Firefox, open DOM Inspector  (by pressing Ctrl+Shift+I)
3.  In DOM Inspector window, press ‘ALT+F’, then press ‘U’ to open the Inspect URL dialog.
4. Place keyboard focus in the text input field labeled “Enter a URL:” and look at the MSAA properties in the Inspect Objects window.  

Here is part of the Inspect Objects output.  Note that the NAME property is null.
Name:	""
Value:	"http://"
Role:	editable text

Expected results:
The MSAA Name property should not be null.  It should be the same as the label for the field, i.e., Name=”Enter a URL:”.
Confirmed, should be an easy fix.
Target Milestone: --- → Firefox 3 alpha1
Assignee: nobody → leofigueres
Attached patch patch (obsolete) — Splinter Review
Sets the value "Enter a URL" to the "Name" field.

It adds a <label> to the layout, but it is hidden so it will not be shown. The "control" attribute links the <label> to the <textbox>.

When this bug was originally filed, there was a "Enter URL" dialog box. Now the same action is achieved from the URL bar. This is the reason why the colon was not used on the localized string.

Another (tested previously) way to get the same is to add a "tooltiptext" attribute to the textbox itself, but it results in a more intrusive way to do it.
Attachment #614034 - Flags: review?(Sevenspade)
Comment on attachment 614034 [details] [diff] [review]
patch

It looks like Firefox gets this for free with the placeholder attribute <http://mxr.mozilla.org/comm-central/source/mozilla/browser/base/content/browser.xul#506>.  SeaMonkey achieves it explicitly through aria-label <http://mxr.mozilla.org/comm-central/source/suite/browser/navigator.xul#289>

With the approach this patch takes, I think simply using aria-label should be equivalent, since the label from this patch will be hidden anyway. Though, I do like the way Firefox does it, since using the placeholder attribute has the nice side effect of, you know, giving you a placeholder, too.

Since I don't know much about a11y anyway, surkov, do you know if there are any details about aria-label and placeholder that make one "better" than the other in this case?

Neil, since SeaMonkey doesn't use a placeholder for its location bar, if placeholder is in fact just as good as aria-label, do you think it would be an affront to SeaMonkey UI choices for DOM Inspector to use a placeholder instead of the invisible aria-label, as navigator does?
Attachment #614034 - Flags: ui-review?(neil)
Attachment #614034 - Flags: feedback?(surkov.alexander)
Er, I shouldn't have used those flags, since comment 3 is for the bug in general, and not for attachment 614034 [details] [diff] [review].
Attachment #614034 - Flags: ui-review?(neil)
Attachment #614034 - Flags: review?(Sevenspade)
Attachment #614034 - Flags: feedback?(surkov.alexander)
Component: Disability Access → DOM Inspector
OS: Windows XP → All
Product: Firefox → Other Applications
QA Contact: disability.access → dom-inspector
Hardware: x86 → All
Target Milestone: Firefox 3 alpha1 → ---
I don't see it making much difference, there's usually a URL in there anyway.
iirc due to bug a11y don't get a name from hidden labels, in this case I think aria-label looks reasonable.
DOMi in SeaMonkey starts with a blank URL textbox. By using placeholder, we could improve also the user-experience.
Javi, aria-label or placeholder, your choice.

Comment on attachment 614034 [details] [diff] [review]
>+<!ENTITY lblEnterURL.label "Enter a URL">

I think replacing "Enter" in the string with "Inspect" would be better, since it's more specific about what's going on (cf "Go to a Website" in the Firefox location bar).  In fact, that's the value of cmdEnterLocation.label.  (I wonder if it can be reused?  I don't know if using the same string would work in other languages, though.)
Attached patch patch 2Splinter Review
Using the placeholder attribute in the textbox and reusing the cmdEnterLocation string.
Attachment #614034 - Attachment is obsolete: true
Attachment #617968 - Flags: review?(Sevenspade)
Attachment #617968 - Flags: review?(Sevenspade) → review+
Pushed:
http://hg.mozilla.org/dom-inspector/rev/98da6415e9bd
Blocks: DOMi2.0.12
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.