"Choose Helper Application", get list from Gnome Menu

RESOLVED DUPLICATE of bug 259594

Status

()

RESOLVED DUPLICATE of bug 259594
12 years ago
10 years ago

People

(Reporter: jordan, Unassigned)

Tracking

1.8.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060614 Fedora/1.5.0.4-1.2.fc5 Firefox/1.5.0.4 pango-text
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060614 Fedora/1.5.0.4-1.2.fc5 Firefox/1.5.0.4 pango-text

(I am using Fedora Core 5, Firefox version 1.5.0.4)

When clicking on a file on a webpage, such as an .mov, the "Opening..." dialog appear, asking whether a user wishes to open the file with an application or simply save it to a specified location on their system.

When the user hits the "Open With" button, they are presented with a file browser. The user then has to go to /usr/bin and wait for the list to load, and then select the correct program.

A better way would be for a list of programs present in the Gnome Menu to be presented to the user when the "Open With" button is pushed, and if the program is not present in that list, the user would press an "Other" button, and be presented with the file browser.

Reproducible: Always

Steps to Reproduce:
1. Open the web browser
2. Click on a link to a file
3. In the "Open" dialog which appears, press "Open With".


Actual Results:  
The user is shown a file browser, which is daunting if they are not familiar with the layout of the Linux file system.

Expected Results:  
A list of programs that the user is familiar with should appear, such as those present in the Gnome menu.
(Reporter)

Comment 1

12 years ago
Created attachment 231601 [details]
Screenshot of "Opening..." dialog

This is a screenshot of the "Opening..." dialog
(Reporter)

Comment 2

12 years ago
Created attachment 231603 [details]
Screenshot of "Choose Helper Application" dialog

This is a screenshot of the "Choose Helper Application" dialog. Notice that the user must navigate through the filesystem to find the program that s/he wishes to use to open the file.

Comment 3

12 years ago
I actually looked into this a few weeks ago and didn't see an easy way to do this.

Comment 4

12 years ago
This bug is a duplicate or at least depends on (or blocks) bug 25959. Both are dealing with the "Open with..." dialog of Firefox in Linux. 

It is interesting to note that a similar issue is being worked on for Windows (see bug 237079). The solution should be pretty similar (that is, call the native "Open with..." dialog of the appropriate Desktop Environment).

Comment 5

12 years ago
(sorry, wrong bug number, corrected below)

This bug is a duplicate or at least depends on (or blocks) bug 259594. Both are
dealing with the "Open with..." dialog of Firefox in Linux. 

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 1.5.0.x Branch
Duplicate of bug: 259594
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.