Closed Bug 346969 Opened 15 years ago Closed 13 years ago

      do not wrap

Categories

(Core :: Layout: Text and Fonts, defect)

1.8 Branch
PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugzilla, Unassigned)

References

(Depends on 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5

http://en.wikipedia.org/wiki/Space_character state that   et al. should not act as a non-breaking space, yet they do.

this might be related to bug 137680, dunno.



Reproducible: Always

Steps to Reproduce:
the following HTML: 

SELECT ·`yvra_adres`.`adresnr`, ·`yvra_adres`.`artikelen`, ·`yvra_adres`.`autokeywords`, ·`yvra_adres`.`categorie`, ·`yvra_adres`.`contact`, ·`yvra_adres`.`creationdt`, ·`yvra_adres`.`creator`, ·`yvra_adres`.`email`, ·`yvra_adres`.`fax`, ·`yvra_adres`.`keywords`, ·

should wrap at the  's, yet they don't.
Component: General → Layout: Fonts and Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: unspecified → 1.8 Branch
Depends on: 56652
Duplicate of this bug: 386890
More generally, as bug 386890 mentions UTR 14 should be implemented. 
Ah, also U+202F is too narrow to indicate French thin space and it is used as such.

See http://fr.wikipedia.org/wiki/Espace_typographique

See <http://wiki.traduc.org/gnomefr/Typographie> and  <http://www.cs.tut.fi/~jkorpela/html/french.html> (English). 

And this one must not break !
U+202F should traditionally be 1/4 em could be a bit thinner but not thinner than &thinsp;
This bug says this happens on Mac OS X, but bug 386890 mentions Windows XP.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; fr; rv:1.9b5) Gecko/2008032619 Firefox/3.0b5

In typography applications we have "breaking spaces" and their equivalent "non-breaking ones"". In Unicodes it looks like they provide for all breaking ones, but they do not list all non-breaking ones.

Space -> available in FF3 and Unicode
Non-breaking space -> available in FF3 and Unicode

Thin space -> available in FF3 and Unicode
Non-breaking thin space -> NOT available in FF3 and Unicode

En space -> available in FF3 and Unicode
Non-breaking En space -> NOT available in FF3 and Unicode

Em space -> available in FF3 and Unicode
Non-breaking Em space -> NOT available in FF3 and Unicode

So, the spaces listed in this bug do all wrap according to specs, at least in FF3.

"&thinsp; &emsp; &ensp;" are wrapping.

In view of this, this bug should be marked WORKSFORME. Specific fix have most problably been done elsewhere.

As for the non-breaking version of these spaces, I think a new version of Unicode will have to be created.

http://www.cs.tut.fi/~jkorpela/html/french.html lists some workaround. But nothing makes it easy to emplement "non-breaking thin spaces", "non-breaking En spaces" and "non-breaking Em spaces".
JrBlier added :

>As for the non-breaking version of these spaces, I think a new version of
>Unicode will have to be created.

If you mean new characters will have to be added, I seriouly doubt it (they are already ways to make then non-breaking in Unicode or through tagging), implementing UTR 14 will already be a good step (xxx&thinsp;! would then not break, see rule LB13)

http://unicode.org/reports/tr14/
Thanks for pointing to LB13 rule. I will follow up in bug 56652.

As for the original intent of this bug, it is clearly fixed. Can someone close this bug?
The original bug description said: « &thinsp; et al. should not act as a non-breaking space, yet they do.»

Are &thinsp et al. now breaking spaces ("BA" property for UTR 14)? If so (in which version of FF ?), then the  bug is indeed closed.
I think all all FF version 3 of FF do wrap: "&thinsp; &emsp; &ensp;". But for sure FFb5 do wrap these three spaces.

ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/3.0b5-candidates/rc2/

Yep, please close this bug.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.