Closed Bug 347080 Opened 14 years ago Closed 14 years ago

Open cross-folder saved search folder doesn't show new messages that arrive in folders that didn't have matching hits when view opened

Categories

(MailNews Core :: Backend, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Details

(Keywords: fixed1.8.1)

Attachments

(1 file, 1 obsolete file)

If you open a cross folder saved search folder, and one of the searched folders doesn't have any hits when you open the saved search folder, if new messages are added to the searched folder that should match the saved search, those messages aren't displayed in the saved search view until you go to an other folder and back to the saved search. The problem is that we don't add a db listener for the folders w/o hits when we open the folder.

For saved searches that search over a bunch of folders, but usually only have hits on a small subset of folders, we might want to use a pending listener, so that we don't hold the db's open...but that would require adding the listeners after the search is done.
Attached patch proposed fix (obsolete) — Splinter Review
use pending listeners for all the folders - this is a slightly scary change, so I'm going to run with it. The nice thing about pending listeners is that they allow you to passively listen to changes for a folder, w/o holding open the db. The db will close if no one is holding onto it, and your listener will re-attach when someone opens the db.
Attached patch proposed fixSplinter Review
as described earlier, this uses pending listeners for virtual folders. It also cleans up some comments, and other miscellaneous stuff.
Attachment #231863 - Attachment is obsolete: true
Attachment #232827 - Flags: superreview?(mscott)
Attachment #232827 - Flags: superreview?(mscott) → superreview+
fixed on trunk and branch - this might solve some mysteries cross-folder virtual folders were seeing.
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.