onkeyup handler does not work

RESOLVED DUPLICATE of bug 344152

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 344152
12 years ago
12 years ago

People

(Reporter: Peter Tolmachov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.5) Gecko/20060723 Firefox/1.5.0.5

javascript code(that is placed in onkeyup handler) is not executed when
button is released(onkeyup event occurs). 

Reproducible: Always

Steps to Reproduce:
1. create an html file (e.g. keyup_problem.html) using content that is in
addtional information:
2. execute it using firefox on MAC platform
3. Press some button on your keyboard
4. press result button


Actual Results:  
Result contains <onkeypress><onchange>

<onkeyup> string is missing which means that addmessage('onkeyup');
javascript code in onkeyup handler is not executed.

Expected Results:  
<onkeypress><onkeyup><onchange> 


<html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
<head>
<title>keyup problem demo</title>
<script type="text/JavaScript">
var result = "";
function showresult()
{
alert(result);
}
function resetresult()
{
result = "";
}
	
function addmessage(message)
{
result = result + "<" + message + ">";
}
</script>
</head>
<body>
<input type="text" name="field" onkeyup="addmessage('onkeyup');" onkeypress="addmessage('onkeypress');" onchange="addmessage('onchange');">
<input type="button" name="field" value="Result" onclick="showresult();">
<input type="button" name="field" value="reset" onclick="resetresult();">
</body>

*** This bug has been marked as a duplicate of 344152 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.