Closed Bug 347516 Opened 18 years ago Closed 18 years ago

crash [@ mozInlineSpellChecker::QueryInterface]

Categories

(Core :: Spelling checker, defect)

1.8 Branch
x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 347561

People

(Reporter: stevee, Assigned: mscott)

References

()

Details

(Keywords: crash)

Crash Data

This bug is reported by Warduke from the mozillazine forums
- http://forums.mozillazine.org/viewtopic.php?p=2412666#2412666
The following information is his:

"Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060804 BonEcho/2.0b1 ID:2006080415

I was looking for something at Google and when I clicked on this link:
- http://www.amazon.com/gp/product/0452284295/103-6353106-4264609?v=glance&n=283155
Firefox crashed. Tried several more times, got both crashes and hangs.

TB21796127Q
TB21796130Z
TB21796148G

I've tried that link a few more times now, and no crash/hang so far."


I am unable to reproduce this crash, but it happened three times to Warduke with three identical stacktraces so I thought i'd file it.
Incident ID: 21796127
Stack Signature	mozInlineSpellChecker::QueryInterface 63f273d8
Product ID	Firefox2
Build ID	2006080409
Trigger Time	2006-08-04 22:30:30.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	spellchk.dll + (00005180)
URL visited	
User Comments	
Since Last Crash	15251 sec
Total Uptime	15251 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
mozInlineSpellChecker::QueryInterface
mozInlineSpellWordUtil::Init  [../mozilla/extensions/spellcheck/src/mozInlineSpellWordUtil.cpp, line 120]
mozInlineSpellChecker::SpellCheckAfterEditorChange  [../mozilla/extensions/spellcheck/src/mozInlineSpellChecker.cpp, line 303]
0x778b0c24
nsComboboxControlFrame::ShowPopup  [../mozilla/layout/forms/nsComboboxControlFrame.cpp, line 565]
nsCSSGroupRule::`vftable'
Assignee: nobody → mscott
Component: General → Spelling checker
Product: Firefox → Core
QA Contact: general → spelling-checker
Version: 2.0 Branch → 1.8 Branch
I'm pretty sure these two bugs you filed are manifestations of the same thing.

*** This bug has been marked as a duplicate of 347561 ***
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ mozInlineSpellChecker::QueryInterface]
You need to log in before you can comment on or make changes to this bug.