enable 'auto-sort' for bookmarks-menu following the rules set in bookmark-manager

RESOLVED DUPLICATE of bug 250787

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 250787
12 years ago
12 years ago

People

(Reporter: xtc4uall, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060805 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060805 BonEcho/2.0b1

i'd like to have following small enhancement of bookmark handling:

(let's say you have A-Z ordering set in the bookmarks-manager)

- after you add an bookmark

a) using creation in a certain folder: it should be automatically sorted the way by the rule set in the bookmarks-manager (in this case A-Z ordering)

b) the 'normal' way of just adding to the root: after a 'browsing-session' when you were too lazy to specify adding the bookmark to a certain folder (as described in a) you want to do it afterwards using the bookmark-menu. so you drag'n'drop all those new bookmarks from the root to your destination folders. the dropped bookmark should be sorted automatically following the rule set in the bookmark-manager (in this case A-Z)


the handling now is kinda pedestrian:

after adding bookmarks using methods described in a) or b) you have to open the destination folder for every bookmark (using here the menu or manager makes no difference), right-click an entry & click 'sort-by-name'.

i repeat it again: this should really be done automatically.
above wished behaviour should of course be un-/checkable somewhere.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
maybe this depends on bug 250787 and should be switched to 'places/future'.
Version: unspecified → Trunk

Comment 2

12 years ago
This actually looks like a dupe of that bug. Marking so. But I'm going to add the original report here to that bug as it is clearer. I'll also make the necessary component and target adjustments in that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250787
You need to log in before you can comment on or make changes to this bug.