Closed Bug 34787 Opened 20 years ago Closed 6 years ago

Expand watches to keywords

Categories

(Bugzilla :: Email Notifications, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 278455

People

(Reporter: mj, Unassigned)

References

Details

This could be considered a duplicate of bug 14137.

Currently, you can add a watch to receive emails sent to another bugzilla
account. This can be used for when the watched person is on holiday, etc.

I am using the feature to watch the work of fellow developers, so I get notified
on all bugs related to the Zope Studio project. This gets unworkable as more
people start contributing to Zope Studio and uncover and report more Mozilla
bugs. Some of these people may also be notified of bugs I have no interest in.

Adding a watch on keywords would solve this particular problem for me. Many
keywords are related to specific projects or areas where QA needs to give
special attention (like the beta1 and beta2 keywords).

I think this should be relatively easy to implement, all that is need is a query
for accounts that have a watch on the keywords specified in the bug.
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
I want this feature as well. I want to be emailed about changes to all bugs with
the "access" keyword.
This is also important in that many people use tracking bugs rather than
keywords due to the lack of this feature, because trackers give dep change
notifications for new bugs in that category.
Hopefully we can get to this early in the BZ3 line, I don't think we should be
doing something like this in the BZ2 line, as much as I want it.
Component: Bugzilla → Bugzilla 3
Target Milestone: --- → Bugzilla 3.2
The Bugzilla 3 component is going away.  We're going to depend on the Milestones 
for this.  At the time this component was created, we didn't have milestones for 
Bugzilla.
Component: Bugzilla 3 → Bugzilla
-> Bugzilla product, Email component (watching), reassigning to Myk for
evaluation.
Assignee: tara → myk
Component: Bugzilla → Email
Product: Webtools → Bugzilla
Version: other → unspecified
I'm wary of adding any additional watches until bug 73665 is checked in.  This
should give us the ability to add new watches quickly, eaily, and with filter
preferences.
Depends on: emailprefs
Blocks: 86547
Summary: [RFE] Expand watches to keywords → Expand watches to keywords
Depends on: 298471
*** Bug 69253 has been marked as a duplicate of this bug. ***
QA Contact: mattyt-bugzilla → default-qa
Assignee: myk → email-notifications
Bugzilla 3.2 is now frozen. Only enhancements blocking 3.2 or specifically approved for 3.2 may be checked in to the 3.2 branch. If you would like to nominate your enhancement for Bugzilla 3.2, set the "blocking3.2" flag to "?". Then, either the target milestone will be changed back, or the blocking3.2 flag will be granted, if we will accept this enhancement for Bugzilla 3.2.

This particular bug has not been touched in over eight months, and thus is being retargeted to "---" instead of "Bugzilla 4.0". If you believe this is a mistake, feel free to retarget it to Bugzilla 4.0.
Target Milestone: Bugzilla 3.2 → ---
Sounds like this would be resolved by general field watching.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: bz-field-watch
You need to log in before you can comment on or make changes to this bug.