Selection won't go out of blocks with overflow-x: auto

VERIFIED DUPLICATE of bug 42676

Status

()

Core
Selection
VERIFIED DUPLICATE of bug 42676
12 years ago
10 years ago

People

(Reporter: Benjamin Smedberg, Assigned: roc)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
If you have a block (maybe just a pre?) with overflow-x: auto, and you start selecting with the mouse in side the block, you cannot extend the selection outside of the block. Testcase forthwith. This is not a problem with 1.8 branch, only trunk.
(Reporter)

Comment 1

12 years ago
Created attachment 232750 [details]
Testcase HTML
(Reporter)

Updated

12 years ago
Whiteboard: [regression date wanted]
(Reporter)

Comment 2

12 years ago
bz says that since overflow-x causes a scrollable view that perhaps this isn't quite as incorrect as I thought. And that it's only a regression from 1.8 in that we started supporting overflow-x. I'd still expect selection to work within the same document, however.
Assignee: nobody → roc
Component: Layout: Block and Inline → Layout: View Rendering
Keywords: regression
QA Contact: layout.block-and-inline → ian
Whiteboard: [regression date wanted]
I do see a regression but only a very old one: between 2004-09-04:07 and 2004-09-05:07. In newer builds I see the same behaviour: impossible to select the third line when you start selecting in the second line.

Comment 4

12 years ago
When I narrow the browser window so that the sentence in the pre tag in the testcase does not fit anymore there is no horizontal scrollbar given unless I set a height on the pre block.  

This is not a problem with a div that has white-space:nowrap.  The div is made taller and a horizontal scrollbar is added.
(In reply to comment #4)
> When I narrow the browser window so that the sentence in the pre tag in the
> testcase does not fit anymore there is no horizontal scrollbar given unless I
> set a height on the pre block.  

That works for me. Try increasing the font size; narrowing the browser window can mislead you because at some point the content area stays the same size and stars overflowing the browser window.

Comment 6

12 years ago
Ok but then why doesn't a horizontal scrollbar appear at the bottom of the page in that case when the minimum content size is reached?
What's happening is that the browser UI is overflowing its window. If you make the window narrow enough you will see that e.g. the "busy" spinner in the top right gets cut off

Updated

10 years ago
Blocks: 458987

Updated

10 years ago
Component: Layout: View Rendering → Selection
QA Contact: ian → selection
This is just a special case of bug 42676.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 42676

Updated

10 years ago
No longer blocks: 458987
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.