Closed Bug 347895 Opened 13 years ago Closed 13 years ago

Right click on an embedded flash object crashes Firefox; no talkback available

Categories

(Core :: Plug-ins, defect, critical)

1.8 Branch
x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: softexpert, Unassigned)

References

()

Details

(Keywords: crash, regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060808 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060808 BonEcho/2.0b1

While checking bug #271442 and it's testcase, I found what seems to be a regression:
 Right click on a flash object instantly crashes Firefox and when re-launching it there is no talkback report.
I tested this with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060808 BonEcho/2.0b1 ID:2006080804, with a _new_ profile, no extension installed. 
The nightly before did not have this issue!

Reproducible: Always

Steps to Reproduce:
1. Goto http://stuff.novemberborn.net/sifr/overflow-bug.html
2. Right click on the flash objects
3.

Actual Results:  
Firefox crashes

Expected Results:  
Flash context menu should appear

The relevant output from strace:
><snip><
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 438 error_code 2 request_code 12 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[{WIFEXITED(s) && WEXITSTATUS(s) == 1}], 0) = 15434
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
><snip><
Depends on: 271442
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060808 BonEcho/2.0b1

I can't reproduce this, bug this /has/ happened to me before. If you could do two things it would be very helpful. One, attach your xorg config. (usually in /etc/X11/xorg.conf) to the bug, and two, tell us what version of Flash you're using (it'll be in about:plugins).
Severity: major → critical
Keywords: crash
Version: Trunk → 1.8 Branch
we already have a general bug about xerrors, your bug can be a duplciate of that, or we can complain about this to adobe.
Component: Layout → Plug-ins
QA Contact: layout → plugins
Attached file My XOrg config file
This is my XOrg configuration file.
I have a Compaq with an ATI Radeon Mobility U1.
I have Shockwave Flash 7.0 r63.
The same plugin in Konqueror 3.5.3-0.4.FC5 works flawless.

On another machine with a NVIDIA GeForce 2MX I cannot reproduce the bug. I updated to latest nightly and it works. (It has the same plugin version)

There is absolutely a bug introduced with this build (2006080804), because I was just checked before updating (from 2006080704 to 2006080804) the bug #271442.
Attachment #232784 - Attachment mime type: application/octet-stream → text/plain
Marian, interested in seeing when this regressed for you on trunk builds?
It might give an indication which patch is responsible.
Interesting discovery: after fiddling with my drivers (setting radeon, then ati, then installing latest and greatest from ATI) now I can right click on the flash objects.
I cannot reproduce anymore the crash !
Seems that it has something to do with a specific driver version in a specific configuration ...

What can I do to sort this out?
Doesn't seem like a Firefox bug to me, then.
No longer depends on: 271442
(In reply to comment #7)
> Doesn't seem like a Firefox bug to me, then.
> 

Well, not exactly !
Remember that only Firefox crashed, while Konqueror was safe on _exactly the same_ conditions! In parallel, FF kept crashing while Konqueror was OK ... 
I would say that there is a very hard to find, well hidden bug, that will show up only in a _particular_ situation. Who can say how many particular situations are out there?
Not reproducing it now does not mean that Firefox will be safe forever ...

However, it's up to you to decide what next. 
Sorry for taking your time with this issue. 
IJWTH (I Just Want To Help)
If you ever feel like installing the old driver, xorg-debug, etc. and doing some debugging, please let me know. For now this is invalid. ->INVALID
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.