Placing 'insertion point" does not remove highlighting from url in Location field

VERIFIED DUPLICATE of bug 87410

Status

()

VERIFIED DUPLICATE of bug 87410
13 years ago
13 years ago

People

(Reporter: bkreps, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

In Internet Explorer for example, when you click at any point in a highlighted url in the Location field, the highlighting is removed and an insertion point is placed  and you may then edit the url.  Firefox does not remove the highlighting unless you first click anywhere in the Location Field and then click a second time where you want the insertion point. 

Reproducible: Always

Steps to Reproduce:
1. Load a web page.
2. Left click anywhere on the page that is not a link.
3. Left click anywhere in the Location field so that the url highlights.
4. Left click anywhere in the url and drag while still holding the left mouse button.
5. A "No" symbol displays.
6. Left click anywhere in the Location field a second time to remove highlighting.
7. Now an insertion point can be set or text can be highlighted.

Actual Results:  
n/a

Expected Results:  
Hightlighting should be released on first click and insertion point placed.

Version 1.5.0.4
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5.0.x Branch

Updated

13 years ago
Assignee: nobody → selection
Component: General → Selection
Product: Firefox → Core
QA Contact: general
Version: 1.5.0.x Branch → 1.8 Branch
This has to have been reported lots of times over the years other than just in bug 163939, but I can't seem to find the right search keywords to get to the others.
Whiteboard: DUPEME
Bug 87410?
Actually, I'm sure it is.

*** This bug has been marked as a duplicate of 87410 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.