Closed Bug 348439 Opened 15 years ago Closed 15 years ago

expose xhtml widget slider for xforms range

Categories

(Core Graveyard :: XForms, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: surkov, Assigned: surkov)

References

Details

(Keywords: fixed1.8.0.8, fixed1.8.1.1)

Attachments

(2 files, 1 obsolete file)

The bug 321311 adds common binding for range controls. Range for xhtml should be extended from it too.
Blocks: 327236
Status: NEW → ASSIGNED
Assignee: xforms → surkov.alexander
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
I have some problems with refactoring since functionality that should be common is evenly distributed through range code. So I think it would be better to separate slider widget from xforms range control in the same manner how we it do for calendar. It will allow us to good reuse the widget for ranges that are bound to different types. The rest code we can move to base range binding. Nice and complex :). But it takes a time. If you agree it's not bad idea then I start to work. And if you don't like to wait for this not small work then I guess you can continue work on bug 331987.
Attached patch slider patch (obsolete) — Splinter Review
Exposing slider widget.
Attachment #234656 - Flags: review?(Olli.Pettay)
Attached file slider test
Blocks: 321311
No longer depends on: 321311
So is the slider code mainly just copy-pasted from current range?
(In reply to comment #4)
> So is the slider code mainly just copy-pasted from current range?
> 

Always where I could. Drawing logic is from current range. Interface is changed.
Comment on attachment 234656 [details] [diff] [review]
slider patch


>+    <content>
>+      <html:span anonid="minlabel"/>
>+      <!-- XXX: width and height set by CSS? -->
>+      <html:canvas tabindex="0" anonid="canvas" width="260" height="40"/>
>+      <html:span anonid="maxlabel"/>

Could you open a new bug for the XXX comment and instead of using XXX use the bug number.


>+    </content>
>+
>+    <implementation>
>+    <!-- interface -->
>+
>+      <!-- Return/set lower bound of values. -->

This should be actually actually Get/set ;)


>+
>+      <property name="sliderBoxObject" readonly="true">

Could you call this something else than xxxBoxObject, since this isn't a real boxobject.
Perhaps sliderControl or sliderController? or what could be better...

>+
>+      <!-- These styles are used to draw the slider.
>+        XXX: The "skin", should be set via CSS?
>+      -->

Open a bug also for this XXX. Btw, could we use "native"/theme colors
(like select1 tries to do).
Attachment #234656 - Flags: review?(Olli.Pettay) → review+
Attached patch slider patch2Splinter Review
I filed bug 350870 for slider widget styling.
Attachment #234656 - Attachment is obsolete: true
Attachment #236238 - Flags: review?(doronr)
Attachment #236238 - Flags: review?(doronr) → review+
checked into trunk for surkov
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Whiteboard: xf-to-branch
Blocks: 352462
Since the bug was marked as fixed then I posted new bug 352462 and changed summary of this one to continue the work.
No longer blocks: 321311
Summary: refactor range for xhtml to use common range binding → expose xhmlt widget slider for xforms range
checked into 1.8.0 branch on 2006/09/21
Keywords: fixed1.8.0.8
checked into 1.8 branch on 2006/11/21
Keywords: fixed1.8.1.1
Whiteboard: xf-to-branch
Summary: expose xhmlt widget slider for xforms range → expose xhtml widget slider for xforms range
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.