Command-Option-F should select the web search box.

VERIFIED FIXED

Status

()

VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: web, Assigned: dev)

Tracking

(Depends on: 1 bug)

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1.45 KB, patch
mano
: review+
beltzner
: ui-review+
damons
: approval1.9+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

Command-Option-F is a standard shortcut key for selecting the search bar in many Mac applications (e.g. Safari, iTunes, etc.).  It should be supported in Firefox on the Mac in addition to Command-K.

Reproducible: Always

Comment 1

12 years ago
Sounds like a good idea
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

11 years ago
Created attachment 294547 [details] [diff] [review]
patch

The patch adds Option+Command+F as a secondary shortcut key for the web search bar.
Attachment #294547 - Flags: ui-review?(beltzner)
Comment on attachment 294547 [details] [diff] [review]
patch

Mike, if you want this to land now, you'd have to use the entity used for Accel+F, strings are frozen at this point.
(Assignee)

Comment 4

11 years ago
Ace: Thanks for the review! Patch update coming shortly...
(Assignee)

Comment 5

11 years ago
Created attachment 302555 [details] [diff] [review]
v1.2

The patch *should* work, but isn't - probably due to some new coca keyboard shortcut bugs? 

Oddly enough: if you hit CMD+F to open the find bar, the patch works perfectly.  Without the find bar open, it doesn't.
Attachment #294547 - Attachment is obsolete: true
Attachment #302555 - Flags: ui-review?(beltzner)
Attachment #302555 - Flags: review?(mano)
Attachment #294547 - Flags: ui-review?(beltzner)
Comment on attachment 302555 [details] [diff] [review]
v1.2

ui-r=beltzner, supporting the user's memory for keyboard shortcuts on the OS seems right to me
Attachment #302555 - Flags: ui-review?(beltzner) → ui-review+
Comment on attachment 302555 [details] [diff] [review]
v1.2

a1.9+=damons
Attachment #302555 - Flags: approval1.9? → approval1.9+
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

11 years ago
Assignee: nobody → dev
Status: ASSIGNED → NEW
mozilla/browser/base/content/browser-sets.inc 1.112
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008022504 Minefield/3.0b4pre ID:2008022504
Status: RESOLVED → VERIFIED
Hardware: Macintosh → All
Version: unspecified → Trunk

Updated

11 years ago
Depends on: 419726

Comment 11

11 years ago
It stopped working with the latest nightly.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9pre) Gecko/2008041504 Minefield/3.0pre

Comment 12

11 years ago
I've tested several builds from http://hourly-archive.localgho.st/mac.html
and it stopped working between build 20080414_2047 and 20080414_2130 

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1208231220&maxdate=1208233799
looks like a regression by bug 359638
Please file a new bug and add bug 359638 to the blocking list. It has nothing to do with this bug. Thanks. 

Comment 14

11 years ago
(In reply to comment #13)
> Please file a new bug and add bug 359638 to the blocking list. It has nothing
> to do with this bug. Thanks. 
> 

Filed Bug 429160.  Sorry for the bug spam.
You need to log in before you can comment on or make changes to this bug.