Closed Bug 348487 Opened 14 years ago Closed 14 years ago

Firefox doesn't allow the http:// protocol in page links

Categories

(Toolkit :: Find Toolbar, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: ajiadic, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Because my page uses PHP for the menu and all files are in subfolders, I use php code that reads a file and prints it.  This is the code for the link

<a href="http:\\leakypipe.fileplace.biz\about.html">About Us</a>

Firefox interprets this as "http://leakypipe.fileplace.biz/%5C%5Cleakypipe.fileplace.biz%5Cabout%5Cindex.php"

Reproducible: Always

Steps to Reproduce:
1.Go to my page
2.Click on one of the links

Actual Results:  
I got a server error that said the requested page was not found

Expected Results:  
Gone to the link's href

I happen to notice that the link uses backslashes, and it should use forward slashes. ( \, not /). I think that is contributing to the problem, but firefox should turn all backslashes into forward slashes
RFC 2396 forbids the backslash from being used in URIs and requires that user agents escape it (\ = %5C). If you're using PHP, you should just use str_replace() to change the backslashes to forwardslashes.

*** This bug has been marked as a duplicate of 64488 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.