When clicking links, the page will sometimes jump back to the top of the page.

RESOLVED DUPLICATE of bug 351491

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 351491
12 years ago
12 years ago

People

(Reporter: David Scaglione, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

A perfect example of this is to go to www.dealram.com and select "Find By System".

A small Javascript window will popup and you can select from about 200 different systems. If you scroll down and select a link that isn't within the first viewable page of this list, it jumps back to the top of the list and you have to scroll down again and select your choice again. It works the second time.

Reproducible: Sometimes



Expected Results:  
The software should allow me to click on my choice the first time without having to scroll down again.
(Reporter)

Comment 1

12 years ago
This also happens in my MailEnable administration client. This, of course, is a password protected resource, so I can't give you an example URL to test with that.

Comment 2

12 years ago
Occasionally, on any website, links will take me to the top of the page instead of the proper destination. I can't give a location where it happens all the time for me, but the dealram.com example is a good one.

Comment 3

12 years ago
I have also had this, I am running Mac OS 10.4.7.  I have not noticed any pattern as to when it does it.
(Reporter)

Comment 4

12 years ago
This bug appears to be fixed in v2 RC2.

I have tested it on all the pages I originally mentioned and the error does not occur anymore.

Can anyone else confirm?

Comment 5

12 years ago
I've installed RC2 and this problem still occurs for me.

Comment 6

12 years ago
(In reply to comment #5)
> I've installed RC2 and this problem still occurs for me.
> 

Yes, this has happened for me in both Firefox 2 RC1 and still in RC2.  Never used to happen in previous versions of firefox.

It's fairly intermittent... just click a URL, and the page jumps back to the top (sort of like when you click a # hyperlink that brings you to a location on the same page).

Then, you scroll back down to the link, click it a second, and it then works as expected.

Annoying, but at least it doesn't seem to crash anything.

Using WinXP

Comment 7

12 years ago
For me this bug also began with RC1 and is still around in RC2.
Quite annoying on some pages. I couldn't find a pattern though, which pages trigger this bug...

Comment 8

12 years ago
I have just installed v2, RC 3, and this problem still occurs for me. The dealram.com example on the first comment still seems to be a really good example of this bug.

Comment 9

12 years ago
This bug still occurs in the latest Mac OS X trunk builds (as of 10/18).

Comment 10

12 years ago
Do you guys have caret browsing enabled? 

Comment 11

12 years ago
> Do you guys have caret browsing enabled? 

Yes, caret browsing is enabled. I've now disabled this feature and do some testing.
(Reporter)

Comment 12

12 years ago
I think the bigger question is: Why is this enabled by default now?

This should be changed back to what it was in previous versions. If we want FF to gain full acceptance we need to remove any obstacles for non-technical users.

Comment 13

12 years ago
Caret browsing is not (and has never been) enabled by default.

*** This bug has been marked as a duplicate of 351491 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.