increase color intensity of tab overflow animation

RESOLVED FIXED in Firefox 2

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Jay Goldman)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
PowerPC
Mac OS X
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change], URL)

Attachments

(3 attachments)

increase color intensity of tab overflow animation

once bug #347783 lands, and we start using:

http://lxr.mozilla.org/mozilla1.8/source/toolkit/themes/pinstripe/global/alltabs-box-overflow-bkgnd-animate.png
http://lxr.mozilla.org/mozilla1.8/source/toolkit/themes/pinstripe/global/tab-arrow-start-bkgnd-animate.png
http://lxr.mozilla.org/mozilla1.8/source/toolkit/themes/pinstripe/global/tab-arrow-end-bkgnd-animate.png

I think people will think the animation is too faint.

let me attach a screen shot of the animation at it's "most intense" so that you can see what I mean.
Flags: blocking-firefox2?
Whiteboard: [Fx2 theme change]
Created attachment 233688 [details]
screen shot when opacity of box with animation image is 1.0

Comment 2

12 years ago
Oh... yeah, I thought there was still going to be an orange pulse.  This is way too subtle.  Even a saturated blue would seem kinda wrong to me.

Also, the dropdown AND the scroll arrow are opaque in your screenshot.  That seems wrong.  Only the dropdown should change.
> Oh... yeah, I thought there was still going to be an orange pulse.  This is way
> too subtle.  Even a saturated blue would seem kinda wrong to me.

winstripe will be orange, pinstripe will be blue.  I have orange versions of these images to be used once the rest of the theme refresh lands for winstripe.

> Also, the dropdown AND the scroll arrow are opaque in your screenshot.  That
> seems wrong.  Only the dropdown should change.

that is by design, see https://bugzilla.mozilla.org/show_bug.cgi?id=347783#c5

Updated

12 years ago
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: --- → Firefox 2
(Assignee)

Comment 4

12 years ago
Created attachment 234171 [details]
Pinstripe darker animations

Now that I've had a chance to play with a nightly with the effect in it, it definitely needs to be darker. See attached - you may have some leeway using opacity if you want to play it lighter than this.
Attachment #234171 - Flags: review?(sspitzer)
(Assignee)

Comment 5

12 years ago
Created attachment 234174 [details]
Winstripe darker animations
the new pinstripe version is more pronounced.  the new winstripe version is also more pronounced, but not as much as pinstripe.

note, I just replaced the *animate* icons from your .zip files.  Where the other 2 images in each zip also necessary?
Comment on attachment 234171 [details]
Pinstripe darker animations

the new images look better than the old ones, but passing the buck to eagle eye mconnor to see what he thinks.
Attachment #234171 - Flags: review?(sspitzer)
Attachment #234171 - Flags: review?(mconnor)
Attachment #234171 - Flags: review+
Comment on attachment 234174 [details]
Winstripe darker animations

This are a good win, r+a=me
Attachment #234174 - Flags: review+
Attachment #234174 - Flags: approval1.8.1+
Comment on attachment 234171 [details]
Pinstripe darker animations

These seem a lot darker than the screenshot, but I think the dates were a little off, so the jar stuff wasn't working quite right (I used touch to work around)
Attachment #234171 - Flags: review?(mconnor)
Attachment #234171 - Flags: review+
Attachment #234171 - Flags: approval1.8.1+
landed both sets
Keywords: fixed1.8.1

Comment 11

12 years ago
Can this be RESOLVED FIXED, or are there still open trunk bugs here?

Comment 12

11 years ago
The pulse is indeed faint. I came to Bugzilla to file a request for exactly this feature, without knowing that it exists already. I have been using Firefox 2.0 since it first came out and have never noticed that pulse.

One thing to consider when making the pulsing image is that when users are middle-clicking on links, they're eyes are in the middle of the page and the location of the overflow icon is just outside the range of sharp visual acuity. Objects in this area fall outside the fovea region of the retina, which means that color perception is poor and details are blurred.
I assume this is RESOLVED FIXED?

Correct me if I'm wrong...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.