Closed Bug 348679 Opened 14 years ago Closed 14 years ago

Enable Talkback for Sunbird

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mattwillis, Assigned: mattwillis)

References

Details

Attachments

(4 files, 1 obsolete file)

We should enable Talkback for Sunbird before release so we get better crashreports.
With the help of rhelmer, the following change was made in the MoFo repository:

--- /Users/mwillis/Desktop/Makefile.in  2006-08-14 20:57:03.000000000 -0400
+++ /Users/mwillis/Desktop/Makefile.in.new      2006-08-14 20:54:57.000000000 -0400
@@ -60,25 +60,31 @@ FC_PRODUCT_NAME     = Firefox
 FC_VERSION     = Trunk
 PROG_BASE      = firefox
 else # } { !MOZ_PHOENIX
 ifdef MOZ_THUNDERBIRD
 FC_PRODUCT_NAME        = Thunderbird
 FC_VERSION     = Trunk
 PROG_BASE      = thunderbird
 else # } { !MOZ_THUNDERBIRD
+ifdef MOZ_SUNBIRD
+FC_PRODUCT_NAME        = Sunbird
+FC_VERSION     = Trunk
+PROG_BASE      = sunbird
+else # } { !MOZ_SUNBIRD
 ifeq ($(MOZ_BUILD_APP),macbrowser)
 FC_PRODUCT_NAME        = Camino
 FC_VERSION     = Trunk
 PROG_BASE      = $(warning PROG_BASE is not used for Camino)
 else # } { MOZ_BUILD_APP != macbrowser
 FC_PRODUCT_NAME        = Mozilla
 FC_VERSION     = Trunk
 PROG_BASE      = seamonkey
 endif # } MOZ_BUILD_APP != macbrowser
+endif # } !MOZ_SUNBIRD
 endif # } !MOZ_THUNDERBIRD
 endif # } !MOZ_PHOENIX
 
 # Commandline http tool.
 FC_UTIL                = $(PERL) -I$(FULLSOFT_UTILS) $(FULLSOFT_UTILS)/cmanifest.pl
 
 include $(topsrcdir)/config/config.mk
 
Uncomments talkback so it is added to the optional components list for the NSIS installer
Assignee: nobody → mattwillis
Status: NEW → ASSIGNED
Attachment #233710 - Flags: first-review?(jminta)
Requesting blocking0.3, as this could give us significantly better error reporting, and much of the infrastructure is already in place.
Flags: blocking0.3?
Comment on attachment 233710 [details] [diff] [review]
Enable talkback in the makefile [checked in]

R=JMINTA with a capital woot.
Attachment #233710 - Flags: first-review?(jminta) → first-review+
In bug 347025 comment 6, jay@mozilla.org wrote:
> The only Talkback client change that I know needs to be made is to the Product
> ID in the master.ini file that is packaged into the Talkback xpi (it needs to
> be SunBirdTrunk or SunBird10 depending on your current branch).  Other than
> that, I *thought* Talkback magically works if you build with the Talkback
> "extension" enabled.

Jay,
As evidenced by comment 1, I've made the changes to talkback's Makefile.in that mento said we needed. We'll be shipping Sunbird 0.3 from trunk, so "SunbirdTrunk" sounds appropriate. Would you be able to make the appropriate changes to the master.ini template, or should I continue to try and do this via rhelmer or whomever else has that access and is silly^H^H^H^H^Hbenevolent enough to help me?
Matthew:  I will be out of town for the next week, so I suggest you work with rhelmer or preed to get the master.ini file updated for Sunbird on your build machine.  All that needs to be done is to change "Firefox2" or whatever the product id is to "SunbirdTrunk".  That product id will be good for all builds off your trunk.  Once you branch, we can edit the master.ini on that tinderbox or build machine to "Sunbird10" or whatever you plan to call your branch.  I will be leaving tomorrow afternoon (going to get married in Winnipeg), so if you need anything, ping me int he morning/early afternoon.  Thanks!
Is Bug 323086 still required after this?
Attachment #233710 - Attachment description: Enable talkback in the makefile → Enable talkback in the makefile [checked in]
Attachment #233822 - Flags: first-review?(rhelmer) → first-review+
(In reply to comment #7)
> Is Bug 323086 still required after this?

At least partially. Lightning doesn't upload its symbols to the talkback server, so when Thunderbird crashes due to Lightning and sends a crash report via talkback, the report is really hard to parse. I've seen at least one of these bugs go by already. We'll have to figure out how to handle that later.

In addition, I'm not sure if there are more "hooks" that need to be added to the core code to make talkback reports more informative. 

Once we start getting a report or two from talkback, then we should know better what we want to do with that bug.
This would block an 0.9, but I don't want to hold a release on this since I don't have the impression that we have a clear picture on the amount of work involved/timeline.  Would definitely accept patches though.
Flags: blocking0.3? → blocking0.3-
At the moment, we're running into a make problem on the tinderbox with this.
It looks to me as if most of the other work is complete.

Once #build is on and awake, I'll continue attempting to fix this with them, however it takes a while since I can't reproduce this locally (due to no /mofo repos access), and because talkback builds only on the clobber nightlies. Oh, and on Win32, it takes like 1:45 to build.

mkdir /cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft && cd /cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft && d:/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/build/autoconf/make-makefile -d ..
creating fullsoft/Makefile
make -C /cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft
make: Entering directory `/cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft'
make: *** No rule to make target `Makefile.in', needed by `Makefile'.  Stop.
make: Leaving directory `/cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft'
make -C /cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft fullcircle-push
make: Entering directory `/cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft'
make: *** No rule to make target `Makefile.in', needed by `Makefile'.  Stop.
make: Leaving directory `/cygdrive/d/builds/tinderbox/Sunbird-Trunk/WINNT_5.2_Depend/mozilla/sunbird-obj/fullsoft'


Once this is sussed out, it conceivably is a one line change to the tinder-config.pl of the Mac and Linux tinderboxen to add talkback. Now that I've said that, I'm sure it'll be a science project.
Patch adds Sunbird-specific text, and adds Sunbird to the talkback extension's install.rdf
Attachment #234087 - Flags: first-review?(rhelmer)
Missed the makefiles in the previous patch.
Attachment #234087 - Attachment is obsolete: true
Attachment #234104 - Flags: first-review?(rhelmer)
Attachment #234087 - Flags: first-review?(rhelmer)
After switching off the use of an objdir on the sb-win32-tbox, we are successfully building talkback on nightly clobber builds.  It won't work however, because the Talkback extension's install.rdf doesn't specify Sunbird as a compatible app.

Here is what remains that I know of:
- Get review and check in the patch above to fix the install.rdf issue, and tochange the branding from Netscape Communicator to Sunbird.
- Fix the "Host key verification failed" error when attempting to upload symbols from sb-win32-tbox. 
- Switch on $shiptalkback on galactica and hilo, and switch off the use of an objdir.
- Verify that galactica and hilo can upload their symbols

Attachment #234104 - Flags: first-review?(rhelmer) → first-review+
Comment on attachment 234104 [details] [diff] [review]
Patch C rev1 - Brands QFA for Sunbird and adds Sunbird to install.rdf [checked in]

Patch checked in
Attachment #234104 - Attachment description: Patch C rev1 - Brands QFA for Sunbird and adds Sunbird to install.rdf → Patch C rev1 - Brands QFA for Sunbird and adds Sunbird to install.rdf [checked in]
Attachment #233822 - Attachment description: Changes to talkback Makefile for Sunbird → Changes to talkback Makefile for Sunbird [checked in]
Comment on attachment 234815 [details] [diff] [review]
patch D - rev0 - enables talkback on linux and mac for Sunbird

Looks good
Attachment #234815 - Flags: first-review?(preed) → first-review+
(In reply to comment #14)
> - Get review and check in the patch above to fix the install.rdf issue, and
> tochange the branding from Netscape Communicator to Sunbird.
Done.

> - Fix the "Host key verification failed" error when attempting to upload
> symbols from sb-win32-tbox. 
Done.

> - Switch on $shiptalkback on galactica and hilo
Done.
>      and switch off the use of an objdir.
NOT done, per bsmedberg. We're only doing this on Windows, and it's a bug. 

> - Verify that galactica and hilo can upload their symbols
Done.


Spinoffs:
 - bug 349623 - win32 objdir issue
 - bug 349625 - adding "SunbirdTrunk" to talkback web tool

The latest clobber nightlies all have talkback.

I deem us talkbackified.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
*** Bug 323086 has been marked as a duplicate of this bug. ***
I can verify that talkback is in, but it didn't "get active" yet ^^
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060821 Calendar/0.3a2+
Status: RESOLVED → VERIFIED
I added the "SunbirdTrunk" product to http://talkback-public.mozilla.org/search/start.jsp so that you can query for crashes.

A basic query for all "SunbirdTrunk" crashes is showing some good data, but I am seeing the same problem with the stack traces as we have with the FirefoxTrunk crash reports (they're missing source file and line no. info).  I think I know what the problem is and there is already a bug on that, so I will try to fix that soon.

In the meantime, enjoy your new Sunbird Talkback data. :-)
http://talkback-public.mozilla.org/search/start.jsp?search=1&searchby=stacksig&match=contains&searchfor=&vendor=MozillaOrg&product=SunbirdTrunk&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid&rlimit=500
You need to log in before you can comment on or make changes to this bug.