Database access / statement creation fails, event creation not possible

VERIFIED FIXED

Status

--
major
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: ssitter, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
Database access / statement creation fails, event creation not possible

Steps to Reproduce:
1. Start Sunbird with clean profile
2. Check error console

Actual Results:
About 20 error messages similar to:
Error: mozStorage exception: createStatement failed, statement: 'SELECT * FROM cal_events WHERE id = :id AND recurrence_id IS NULL LIMIT 1', error: 'no such table: cal_events'
Source File: file:///D:/sunbird/components/calStorageCalendar.js Line: 113

Error: uncaught exception: [Exception... "'[JavaScript Error: "this.mSelectEventsByRange has no properties" {file: "file:///D:/sunbird/components/calStorageCalendar.js" line: 638}]' when calling method: [calICalendar::getItems]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///D:/Programme/sunbird/components/calCompositeCalendar.js :: anonymous :: line 357"  data: yes]

Additional Information:
Fails in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060816 Calendar/0.3a2+. Same with linux build.

Fails with Lightning/0.1+ (2006-08-16-06-trunk).
Works with Lightning/0.1+ (2006-08-16-06-mozilla1.8).
(Reporter)

Comment 1

12 years ago
Works in Sunbird/0.3a2+ (2006-08-15-12) win32 build.
Fails in Sunbird/0.3a2+ (2006-08-15-23) win32 build.

Checkins: [http://tinyurl.com/mc5ry]

Comment 2

12 years ago
mrbkap says he knows what's going on here and is going to fix it in a spidermonkey bug on 'let'.  He also says he's not responsible for it, so I'm blaming mrkbap.  Should be fixed shortly after the tree reopens.

Updated

12 years ago
Depends on: 336379
Fixed now, not sure the dependency on bug 336379 is worth it since that bug will remain open a while longer, for other patches to be written and landed, and blocking bugs to be fixed.

/be
Marking fixed, please verify.

/be
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

12 years ago
VERIFIED. No errors with win32 and linux Sunbird/0.3a2+ (2006081706) build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.