[IME] [regression] Need to hit backspace twice to delete the last char

VERIFIED FIXED in M16

Status

()

P3
normal
VERIFIED FIXED
19 years ago
9 years ago

People

(Reporter: teruko, Assigned: mozeditor)

Tracking

({inputmethod})

Trunk
x86
Windows NT
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When you use IME to type Japanese characters,you can use Backspace
to delete the characters before you commit. However,you need to
hit Backspace twice to delete the last Japanese character.

Steps of reproduce
1. Open Composer
2. Turn on IME
3. Type "あいう" (do not hit enter to commit at this time)
4. Hit backspace twice 
   Now, only "あ" is left.
5. Hit backspace once
   This last character "あ" is not deleted.
6. Hit backspace again
   The last character is now deleted. 

Tested 2000040609 Win32 and Mac build.

Comment 1

19 years ago
looks like similar regression as the ESC problem. Joe- did you change some code 
recently ?
Assignee: ftang → jfrancis

Updated

19 years ago
Summary: [IME] Need to hit backspace twice to delete the last char → [IME] [regression] Need to hit backspace twice to delete the last char

Updated

19 years ago
Blocks: 35012

Comment 2

19 years ago
teruko--is this cross-platform or Windows-specific?
Target Milestone: --- → M16
(Assignee)

Comment 3

19 years ago
cant reproduce this on mac or windows.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

19 years ago
ok, Teruko got this to happen for me.  Thanks!  reopening...
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 5

19 years ago
ok, i have a fix for this which will get checked in tonight.
(Assignee)

Comment 6

19 years ago
fixed
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

19 years ago
I verified this in 2000041410 M16 Win32 build.
Status: RESOLVED → VERIFIED
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.