Mail manually marked as Junk should not be marked "read"

RESOLVED DUPLICATE of bug 306026

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 306026
12 years ago
12 years ago

People

(Reporter: Oliver Kluge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.6) Gecko/20060730 SeaMonkey/1.0.4
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.0.6) Gecko/20060730 SeaMonkey/1.0.4

If you manually mark any mail in the Inbox to be Junk, the default behaviour is to move it to the Junk folder, which is okay. Up to Mozilla 1.7.13 the "read" status was retained, i.e. if the mail was unread, it remained unread.

In Seamonkey 1.04 the mail gets marked "read", which is incorrect. I hope it does not get read in the background, which could (if HTML is enabled) mean that web bugs get loaded, thus producing even more spam...


Reproducible: Always

Steps to Reproduce:
1.Mark any unread mail as being Junk
2.Look into Junk folder
3.

Actual Results:  
Mail has been moved to Junk folder and marked "read".

Expected Results:  
"read" status should remain unchanged.

Comment 1

12 years ago
Already fixed for TB 2.0.

*** This bug has been marked as a duplicate of 306026 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.