Reloading form with select element don't reflect/render changes for selected option

RESOLVED DUPLICATE of bug 46845

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 46845
11 years ago
11 years ago

People

(Reporter: martinl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

First load show "(no action)" as selected:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <title>Firefox bug</title>
  </head>
  <body>
    <h1>Firefox bug</h1>
    <hr>
    <form action="" method="post">
      <select name="cur_cmd_id">
	<option value="0" selected="selected">(no action)</option>
	<option value="1">start</option>
	<option value="2">stop</option>
	<option value="3">next step</option>        
	<option value="4">next order</option>
      </select>
      <input name="btnSubmit" value="Save" type="submit" />
    </form>
  </body>
</html>

A reload after changing selected don't reflect the changes except in "View - Page Source". The select element is still shown with "(no action)" selected:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>
    <title>Firefox bug</title>
  </head>
  <body>
    <h1>Firefox bug</h1>
    <hr>
    <form action="" method="post">
      <select name="cur_cmd_id">
	<option value="0">(no action)</option>
	<option value="1" selected="selected">start</option>
	<option value="2">stop</option>
	<option value="3">next step</option>
        
	<option value="4">next order</option>
      </select>
      <input name="btnSubmit" value="Save" type="submit" />
    </form>
  </body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Make a form with select element with a selected option
2. Move selected to another option
3. Reload the page

Actual Results:  
The element is not updated except in "View - Page Source".

Expected Results:  
An element reflecting the change.

IE shows correct behaviour ...
You need to enter another page and then when rentering the problem page it's rendered ok.

Comment 1

11 years ago
That's probably because "reload" doesn't change form-elments-values.
Try Ctrl+F5 or Ctrl+Shift+R and let us know that solve the problem.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.